adb: added patch for openssl 1.1.0 compatibility
[openwrt/staging/mkresin.git] / package / utils / adb / Makefile
index 1e77bb7e8a0809c9219ec44532f8465ac5adb4bc..55f9c1a598622ef91cb650a40dd650a0d4583222 100644 (file)
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adb
 PKG_VERSION:=android.5.0.2_r1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://android.googlesource.com/platform/system/core
@@ -28,7 +28,7 @@ define Package/adb
   DEPENDS:=+zlib +libopenssl +libpthread
 endef
 
-define Package/bridge/description
+define Package/adb/description
  Android Debug Bridge (adb) is a versatile command line tool that lets you communicate with an emulator instance or connected Android-powered device.
 endef
 
@@ -40,7 +40,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/adb/ \
                $(TARGET_CONFIGURE_OPTS) \
                TARGET=Linux \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)"
 endef