ath79: ag71xx: Rework mdio clock settings
[openwrt/staging/mkresin.git] / rules.mk
index b1ecc24fab1f9a97a4dd4a7a5c17753996003977..d90e0ffed09867bc3f39278b7109cdfa523391f1 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -141,6 +141,10 @@ endif
 
 ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_GCC_VERSION_4_8),$(CONFIG_TARGET_uml)),)
   iremap = -iremap$(1):$(2)
+  # just overwrite iremap for GCC 8.1 and higher to keep backward compatibility
+  ifeq ($(CONFIG_GCC_VERSION_8),y)
+    iremap = -fmacro-prefix-map=$(1)=$(2)
+  endif
 endif
 
 PACKAGE_DIR:=$(BIN_DIR)/packages