add prereq checks for target/linux/* and target/image/*, check for fdisk for the...
[openwrt/staging/mkresin.git] / target / Makefile
index dc21033e5f6bd04caed4d04657f7e77c364614b8..c00eea0d66fa838ff0eabd4edde47b3594aaa9f5 100644 (file)
@@ -25,6 +25,10 @@ compile: linux-compile image_compile
 install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
 clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
 
+prereq: FORCE
+       $(MAKE) -C linux/$(BOARD)-$(KERNEL) prereq
+       $(MAKE) -C image/$(BOARD) prereq
+
 image_clean: FORCE
        $(MAKE) -C image/$(BOARD) clean
        rm -f $(BIN_DIR)/openwrt-*