gemini: follow common pattern for temp dir naming
[openwrt/staging/mkresin.git] / target / linux / gemini / image / Makefile
index b631452a0ffb63984fb86329f1f1bf27668c965f..a55a89070076d70e85474f77bb47d1d1ab7243b0 100644 (file)
@@ -12,12 +12,14 @@ include $(INCLUDE_DIR)/image.mk
 # D-Link devices.
 define Build/dir685-images
        mkwrggimg -i $(IMAGE_KERNEL) \
-       -o $(BIN_DIR)/$(IMG_PREFIX)-dir685-fwupdate.bin \
+       -o $@.new \
        -d /dev/mtdblock/1 \
        -s wrgns01_dlwbr_dir685RBWW \
        -v 'N/A' \
        -m dir685 \
        -B 96bb
+
+       mv $@.new $@
 endef
 
 # Build D-Link DNS-313 images using the special header tool.
@@ -25,33 +27,43 @@ endef
 # to satisfy the boot loader on the device. The zImage is
 # the only real content.
 define Build/dns313-images
-       if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
-       mkdir -p $(BIN_DIR)/.boot
-       echo "dummy" > $(BIN_DIR)/.boot/dummyfile
-       dns313-header $(BIN_DIR)/.boot/dummyfile \
-               $(BIN_DIR)/.boot/rootfs.tgz
-       dns313-header $(BIN_DIR)/.boot/dummyfile \
-               $(BIN_DIR)/.boot/rd.gz
+       mkdir -p $@.tmp/.boot
+
+       echo "dummy" > $@.tmp/dummyfile
+
+       dns313-header $@.tmp/dummyfile \
+               $@.tmp/.boot/rootfs.tgz
+       dns313-header $@.tmp/dummyfile \
+               $@.tmp/.boot/rd.gz
        dns313-header $(IMAGE_KERNEL) \
-               $(BIN_DIR)/.boot/zImage
-       rm -f $(BIN_DIR)/.boot/dummyfile
-       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-dns313-bootpart.tar.gz .boot)
-       if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
+               $@.tmp/.boot/zImage
+
+       tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ \
+               -C $@.tmp .boot \
+               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)")
+
+       rm -rf $@.tmp
 endef
 
-# Create the special NAS4220B image format with the squashfs
-# split across two "partitions" named rd.gz and hddapp.tgz but
-# essentially just being used by OpenWRT as one big partition
-define Build/nas4220b-images
-       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/rd.gz bs=6144k conv=sync
-       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
-       cp $(IMAGE_KERNEL) $(BIN_DIR)/zImage
-       cp ./ImageInfo-ib4220 $(BIN_DIR)/ImageInfo
-       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-ib4220b.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
-       mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-rd.gz
-       mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-hddapp.tgz
-       mv $(BIN_DIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-zImage
-       rm -f $(BIN_DIR)/ImageInfo
+# Create the special NAS4220B and Itian Square One SQ201 image
+# format with the squashfs and overlay inside the "rd.gz" file.
+# We pad it out to 6144K which is the size of the initramfs partition.
+#
+# The "application" partition is just blank. You can put anything
+# there when using OpenWRT. We just use that to create the
+# "sysupgrade" firmware image.
+define Build/nas4220b-sq201-images
+       mkdir -p $@.tmp
+
+       mv $@ $@.tmp/rd.gz
+       dd if=/dev/zero of=$@.tmp/hddapp.tgz bs=6144k count=1
+       cp $(IMAGE_KERNEL) $@.tmp/zImage
+       cp ./ImageInfo-$(1) $@.tmp/ImageInfo
+
+       (cd $@.tmp; tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ * \
+               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)"))
+
+       rm -rf $@.tmp
 endef
 
 # WBD-111 and WBD-222:
@@ -67,12 +79,13 @@ endef
 
 # All DTB files are prefixed with "gemini-"
 define Device/Default
+       PROFILES := Default
        DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
        FILESYSTEMS := squashfs
-       IMAGE_NAME := $$(IMAGE_PREFIX)-$$(1).$$(2)
+       IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
        BLOCKSIZE := 128k
        PAGESIZE := 2048
 endef
@@ -89,25 +102,33 @@ GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
 define Device/dlink-dir-685
        DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
-                       kmod-switch-rtl8366rb swconfig
-       IMAGES += dir685-image
-       IMAGE/dir685-image := dir685-images
+                       kmod-switch-rtl8366rb swconfig \
+                       rt2800-pci
+       IMAGES := fwupdate.bin
+       IMAGE/fwupdate.bin := dir685-images
 endef
 TARGET_DEVICES += dlink-dir-685
 
 define Device/dlink-dns-313
        DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-       IMAGES += dns313-image
-       IMAGE/dns313-image := dns313-images
+       IMAGES := dns313-bootpart.tar.gz
+       IMAGE/dns313-bootpart.tar.gz := dns313-images
 endef
 TARGET_DEVICES += dlink-dns-313
 
+define Device/nas4220b-sq201
+       ARTIFACTS := zImage
+       ARTIFACT/zImage := append-kernel
+       IMAGES += rd.gz sysupgrade.tar.gz
+       IMAGE/rd.gz := append-rootfs | pad-to 6144k
+       IMAGE/sysupgrade.tar.gz := append-rootfs | pad-to 6144k | nas4220b-sq201-images $(1)
+       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+endef
+
 define Device/nas4220b
+       $(Device/nas4220b-sq201)
        DEVICE_TITLE := Raidsonic NAS IB-4220-B
-       IMAGES += nas4220b-image
-       IMAGE/nas4220b-image := nas4220b-images
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
 TARGET_DEVICES += nas4220b
 
@@ -118,8 +139,9 @@ endef
 TARGET_DEVICES += rut1xx
 
 define Device/sq201
+       $(Device/nas4220b-sq201)
        DEVICE_TITLE := ITian Square One SQ201
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci-firmware
+       DEVICE_PACKAGES += rt61-pci usb2-pci
 endef
 TARGET_DEVICES += sq201