dnsmasq: full: disable ipset support by default
[openwrt/staging/mkresin.git] / tools / ccache / Makefile
index 21123b316db45d32f89b70ec7231b43e698b37bd..9b2937dccd64c1e56c0e8b838eeda77c6ae5b0df 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,37 +8,34 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=3.1.3
+PKG_VERSION:=4.6
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=b952d75e9ca37209d608ea58d84135cd
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
+PKG_HASH:=3d2bb860f4359169e640f60cf7cc11da5fab5fb9aed55230d78141e49c3945e9
 
 include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_HOST_OPTIONS += \
+       -DCMAKE_C_COMPILER_LAUNCHER="" \
+       -DCMAKE_CXX_COMPILER_LAUNCHER="" \
+       -DCMAKE_SKIP_RPATH=FALSE \
+       -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+       -DREDIS_STORAGE_BACKEND=OFF
 
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Host/Compile
-       $(MAKE) CC="$(HOSTCC_NOCACHE)" -C $(HOST_BUILD_DIR)
-  endef
-
-  define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
-  endef
-else
-  define Host/Prepare
-  endef
-  define Host/Configure
-  endef
-  define Host/Compile
-  endef
-  define Host/Install
-  endef
-  define Host/Clean
-  endef
-  define Download
-  endef
+ifneq (docs-$(CONFIG_BUILD_DOCUMENTATION),docs-y)
+CMAKE_HOST_OPTIONS += -DENABLE_DOCUMENTATION=OFF
 endif
 
+define Host/Install/ccache
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+       $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Install
+       $(call Host/Install/Default)
+       $(call Host/Install/ccache)
+endef
+
 $(eval $(call HostBuild))