ntp: add hotplug class for ntp-events
authorSteven Barth <cyrus@openwrt.org>
Fri, 28 Nov 2014 11:41:25 +0000 (11:41 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 28 Nov 2014 11:41:25 +0000 (11:41 +0000)
Based on a patch by Luiz Angelo Daros de Luca

Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 43421

package/utils/busybox/Makefile
package/utils/busybox/files/ntpd-hotplug [new file with mode: 0755]
package/utils/busybox/files/sysntpd

index 718cf787dcf6cda00612a07d6801398179af68ed..fcfdc8bbefe0e563c85f0fa60e7ca34de94b5a92 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.22.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -116,6 +116,7 @@ define Package/busybox/install
        $(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
        $(INSTALL_BIN) ./files/telnet $(1)/etc/init.d/telnet
        $(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
+       $(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
        -rm -rf $(1)/lib64
 endef
 
diff --git a/package/utils/busybox/files/ntpd-hotplug b/package/utils/busybox/files/ntpd-hotplug
new file mode 100755 (executable)
index 0000000..ddc1490
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+[ "$1" = stratum ] || exit 0
+ACTION="$1" /sbin/hotplug-call ntp
index 417addfb1ca5c0235b8554de1a4368a1385d7964..f73bb83082d76f746ebc52a9e14bb4fba7b9197a 100755 (executable)
@@ -5,6 +5,7 @@ START=98
 
 USE_PROCD=1
 PROG=/usr/sbin/ntpd
+HOTPLUG_SCRIPT=/usr/sbin/ntpd-hotplug
 
 validate_ntp_section() {
        uci_validate_section system timeserver "${1}" \
@@ -26,6 +27,7 @@ start_service() {
        procd_open_instance
        procd_set_param command "$PROG" -n
        [ "$enable_server" = "1" ] && procd_append_param command -l
+       [ -x "$HOTPLUG_SCRIPT" ] && procd_append_param command -S "$HOTPLUG_SCRIPT"
        for peer in $server; do
                procd_append_param command -p $peer
        done