netfilter.mk: add addrtype match to iptables-mod-extra (kmod-ipt-extra)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Jan 2013 16:12:56 +0000 (16:12 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Jan 2013 16:12:56 +0000 (16:12 +0000)
SVN-Revision: 35155

include/netfilter.mk
package/kernel/modules/netfilter.mk
package/network/utils/iptables/Makefile

index 86f35e5fd4b90f923e440081c0254ae32a6fdf85..1d89e6d53919431df5391fd98d1bb8636060f029 100644 (file)
@@ -76,8 +76,7 @@ $(eval $(if $(NF_KMOD),,$(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_TA
 
 # extra
 
-# kernel only
-
+$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_ADDRTYPE, $(if $(NF_KMOD),$(P_XT)xt_addrtype,$(P_XT)ipt_addrtype)))
 $(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_OWNER, $(P_XT)xt_owner))
 $(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PHYSDEV, $(P_XT)xt_physdev))
 $(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PKTTYPE, $(P_XT)xt_pkttype))
index b739a9c28a72ac93d6c264448d1c049c568e8e72..69bdba0fcb692e87cf3fdbc88a7b1c5ffcd79ade 100644 (file)
@@ -377,6 +377,7 @@ endef
 define KernelPackage/ipt-extra/description
  Other Netfilter (IPv4) kernel modules
  Includes:
+ - addrtype
  - owner
  - physdev (if bridge support was enabled in kernel)
  - pkttype
index a3d8864c3ffecfb5c2cc685d7264f9af012ade4f..b9045b17535fc34021949943b24c69b7b997e81c 100644 (file)
@@ -234,6 +234,7 @@ define Package/iptables-mod-extra/description
 Other extra iptables extensions.
 
  Matches:
+  - addrtype
   - condition
   - owner
   - physdev (if ebtables is enabled)