Override kernel template and output bzImage, not the binary file, closes #676 and...
authorFlorian Fainelli <florian@openwrt.org>
Fri, 25 Aug 2006 09:28:15 +0000 (09:28 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 25 Aug 2006 09:28:15 +0000 (09:28 +0000)
SVN-Revision: 4658

openwrt/target/image/x86/Makefile

index d9ed2945747cf0c26bbca3ec3345f31b696bc0cb..919ccbc9fe735fa6110c5d77ceff32010e9bd915 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
 
 define Image/Build
        cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
-       cp $(KDIR)/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+       cp $(LINUX_DIR)/arch/i386/boot/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
 endef
 
 $(eval $(call BuildImage))