mxs: fix image build issues
authorFelix Fietkau <nbd@nbd.name>
Wed, 25 Jan 2017 06:31:01 +0000 (07:31 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 25 Jan 2017 06:48:43 +0000 (07:48 +0100)
stage u-boot images in KERNEL_BUILD_DIR for building images
always select uboot-mxs

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/boot/uboot-mxs/Makefile
target/linux/mxs/image/Makefile

index 66459df65280b7b33901ef6af62bbb1ebba0e7aa..eec78417f2a1813c7b55a5136c5b2c871ddde564 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_VERSION:=2016.01
 PKG_RELEASE:=1
@@ -18,6 +19,8 @@ include $(INCLUDE_DIR)/package.mk
 define U-Boot/Default
   BUILD_TARGET:=mxs
   UBOOT_IMAGE:=u-boot.sb
+  DEFAULT:=y
+  HIDDEN:=1
 endef
 
 define U-Boot/mx23_olinuxino
@@ -32,9 +35,10 @@ UBOOT_TARGETS := \
        mx23_olinuxino \
        duckbill
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CROSS_COMPILE=$(TARGET_CROSS) $(UBOOT_IMAGE)
+UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)
+
+define Build/InstallDev
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)
 endef
 
 $(eval $(call BuildPackage/U-Boot))
index 1daa26e00e9de081bc04bab46fe9f20df6dd161c..f0f1f6acf3da14915372db5e9e009d7ad7361316 100644 (file)
@@ -40,7 +40,7 @@ define Image/Build/SDCard-vfat-ext4
 
        ./gen_sdcard_vfat_ext4.sh \
                $(BIN_DIR)/$(2) \
-               $(BIN_DIR)/uboot-mxs-$(4)/uboot-mxs-$(4).sb \
+               $(KDIR)/$(4)-u-boot.sb \
                $(KDIR)/boot.img \
                $(KDIR)/root.$(1) \
                $(CONFIG_TARGET_BOOTFS_PARTSIZE) \
@@ -51,7 +51,7 @@ endef
 define Image/Build/SDCard-ext4-ext4
        ./gen_sdcard_ext4_ext4.sh \
                $(BIN_DIR)/$(2) \
-               $(BIN_DIR)/uboot-mxs-$(4)/uboot-mxs-$(4).sb \
+               $(KDIR)/$(4)-u-boot.sb \
                $(KDIR)/root.$(1) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE)
        $(call Image/Gzip,$(BIN_DIR)/$(2))