move the EABI config override to the generic kernel config overrides, as it's arch...
authorFelix Fietkau <nbd@openwrt.org>
Sat, 21 Feb 2009 16:26:27 +0000 (16:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 21 Feb 2009 16:26:27 +0000 (16:26 +0000)
SVN-Revision: 14594

include/kernel-defaults.mk
target/linux/ixp4xx/Makefile

index f0639e39fe27f5e9d979fa04e7675c6a2e93cb9f..de07b9118937a258d9aee19170f3e6cfa12a508e 100644 (file)
@@ -91,6 +91,8 @@ define Kernel/Configure/Default
        echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
        echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target
        echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config.target
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config.target)
        $(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override
        $(SCRIPT_DIR)/kconfig.pl 'm+' $(LINUX_DIR)/.config.target $(LINUX_DIR)/.config.override > $(LINUX_DIR)/.config
        $(call Kernel/SetInitramfs)
index cfe76d8bced348455f179cce8caf0cf1e29e4f69..1499075f1d18d6504394bdf1f3ff03fe90237511 100644 (file)
@@ -16,12 +16,6 @@ LINUX_VERSION:=2.6.28.6
 
 include $(INCLUDE_DIR)/target.mk
 
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
-
 DEFAULT_PACKAGES += ixp4xx-microcode fconfig
 
 $(eval $(call BuildTarget))