mac80211: fix build on UML
authorNicolas Thill <nico@openwrt.org>
Fri, 26 Jun 2015 00:43:03 +0000 (00:43 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 26 Jun 2015 00:43:03 +0000 (00:43 +0000)
A duplicate include guard prevents inclusion of barrier.h in UML build and this prevents mac80211 from building.

This patch re-enables mac80211 hwsim and renames the include guard.

See https://lists.openwrt.org/pipermail/openwrt-devel/2015-June/033614.html for details.

Signed-off-by: Martin Tippmann <martin.tippmann@gmail.com>
Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 46133

package/kernel/mac80211/Makefile
package/kernel/mac80211/patches/010-fix-uml-build.patch [new file with mode: 0644]

index 344fbd80c50e4d93767aa207417babf68dc4b409..be26348a13f396a559ec32ba2f11cf0a8548e9cc 100644 (file)
@@ -60,7 +60,7 @@ define KernelPackage/mac80211/Default
   SUBMENU:=$(WMENU)
   URL:=https://wireless.wiki.kernel.org/
   MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
-  DEPENDS:=@!TARGET_uml @!LINUX_4_1
+  DEPENDS:=@!LINUX_4_1
 endef
 
 define KernelPackage/cfg80211
diff --git a/package/kernel/mac80211/patches/010-fix-uml-build.patch b/package/kernel/mac80211/patches/010-fix-uml-build.patch
new file mode 100644 (file)
index 0000000..0d53e08
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/backport-include/asm/barrier.h
++++ b/backport-include/asm/barrier.h
+@@ -1,9 +1,9 @@
+-#ifndef __BACKPORT_ASM_GENERIC_BARRIER_H
+-#define __BACKPORT_ASM_GENERIC_BARRIER_H
++#ifndef __BACKPORT_ASM_BARRIER_H
++#define __BACKPORT_ASM_BARRIER_H
+ #include_next <asm/barrier.h>
+ #ifndef dma_rmb
+ #define dma_rmb()     rmb()
+ #endif
+-#endif /* __BACKPORT_ASM_GENERIC_BARRIER_H */
++#endif /* __BACKPORT_ASM_BARRIER_H */