busybox: don't install NTP scripts if NTP isn't configured
authorPhilip Prindeville <philipp@redfish-solutions.com>
Mon, 6 Feb 2017 22:26:49 +0000 (15:26 -0700)
committerFelix Fietkau <nbd@nbd.name>
Mon, 3 Apr 2017 06:49:16 +0000 (08:49 +0200)
If you're using Chrony or NTPD you don't want the busybox NTP server
as well.  Make it's installation truly conditional.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Signed-off-by: Felix Fietkau <nbd@nbd.name> [simplify]
package/utils/busybox/Makefile

index b75b4551dd401b03b3192418e04fdbbaf988933d..48d945718a09a30bade49f33c159b8405d2f16cc 100644 (file)
@@ -112,9 +112,13 @@ endef
 define Package/busybox/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+ifneq ($(CONFIG_BUSYBOX_CONFIG_CROND),)
        $(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
+endif
+ifneq ($(CONFIG_BUSYBOX_CONFIG_NTPD),)
        $(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
        $(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
+endif
        -rm -rf $(1)/lib64
 endef