gpio-button-hotplug: don't build for 3.3 kernels
authorFlorian Fainelli <florian@openwrt.org>
Wed, 12 Mar 2014 22:09:11 +0000 (22:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 12 Mar 2014 22:09:11 +0000 (22:09 +0000)
3.3 kernels do not have the required changes which would make
gpio-button-hotplug work, disallow building on those kernels for now.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39903

package/kernel/gpio-button-hotplug/Makefile

index 1778aadf098f37e8c55e5e410e4e4c2fb81c5601..c947f433ec19182b886fb9e7b16ae0decebdd60e 100644 (file)
@@ -15,6 +15,7 @@ include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/gpio-button-hotplug
   SUBMENU:=Other modules
+  DEPENDS:=@!LINUX_3_3
   TITLE:=Simple GPIO Button Hotplug driver
   FILES:=$(PKG_BUILD_DIR)/gpio-button-hotplug.ko
   AUTOLOAD:=$(call AutoLoad,30,gpio-button-hotplug,1)