kernel: update linux 3.7 to 3.7.3
authorGabor Juhos <juhosg@openwrt.org>
Fri, 18 Jan 2013 11:44:42 +0000 (11:44 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 18 Jan 2013 11:44:42 +0000 (11:44 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35216

17 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.7/500-MIPS-fw-myloader.patch
target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.7/025-bcma_backport.patch
target/linux/generic/patches-3.7/203-kallsyms_uncompressed.patch
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc83xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc40x/patches-3.7/001-powerpc-add-missing-NULL-terminator-to-avoid-boot-pa.patch [deleted file]
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/x86/geos/target.mk

index e20a3e7548102f18a3025445ff22315905833fe7..932f186f2f1444d08271fc325868ecf1068a8251 100644 (file)
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.2)
-  LINUX_KERNEL_MD5SUM:=a6bad0280df3bfec8f91c9aa375826a5
+ifeq ($(LINUX_VERSION),3.7.3)
+  LINUX_KERNEL_MD5SUM:=6b35fb08d229d4c6d246f27c7d475790
 endif
 
 # disable the md5sum check for unknown kernel versions
index 89f8926460883201094b89ec4c35abdc31403d3b..462de16de27016719bdbaebe6d3ab458011c506b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index b95d2581a7433011944e7761f99648f930dfdf56..2a197eda5d13b94627e5223529c50db47ac3bb15 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 
 include $(INCLUDE_DIR)/target.mk
 
index d07aba7f89fc7c884c110e29d922952259d76eeb..3559a27a2ce3be04b643334f0e966467cdf95ea5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -175,6 +175,7 @@ endif
+@@ -180,6 +180,7 @@ endif
  #
  libs-$(CONFIG_ARC)            += arch/mips/fw/arc/
  libs-$(CONFIG_CFE)            += arch/mips/fw/cfe/
index fc05676b83491e7e0f2148fb6d0769ef1a426530..e7e1712b7ee2d33b4b81703b5f2b20364293f261 100644 (file)
  #include <asm/uaccess.h>
  
  #include <linux/proc_fs.h>
-@@ -851,10 +852,10 @@ static void tcp_v6_send_response(struct 
+@@ -851,10 +852,10 @@ static void tcp_v6_send_response(struct
        topt = (__be32 *)(t1 + 1);
  
        if (ts) {
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
                fl6.flowi6_mark = skb->mark;
  
-@@ -1256,7 +1256,7 @@ static int ip6gre_header(struct sk_buff 
+@@ -1256,7 +1256,7 @@ static int ip6gre_header(struct sk_buff
        struct ipv6hdr *ipv6h = (struct ipv6hdr *)skb_push(skb, t->hlen);
        __be16 *p = (__be16 *)(ipv6h+1);
  
index 8835fe9f2ecbee3ae6c6fa8d635dda1f5e877e70..c13a1cb033c9f5f1e72a26d1cff83c51cf919105 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 
 include $(INCLUDE_DIR)/target.mk
 
index fa0ff316183f2ad311039d5b9a0f14ad9148372c..4bd1b11f390790254534e662b8bf557cff3c5f69 100644 (file)
  }
  EXPORT_SYMBOL(bcma_core_mips_irq);
  
-@@ -114,8 +121,8 @@ static void bcma_core_mips_set_irq(struc
+@@ -114,7 +121,7 @@ static void bcma_core_mips_set_irq(struc
                bcma_write32(mdev, BCMA_MIPS_MIPS74K_INTMASK(0),
                            bcma_read32(mdev, BCMA_MIPS_MIPS74K_INTMASK(0)) &
                            ~(1 << irqflag));
 -      else
--              bcma_write32(mdev, BCMA_MIPS_MIPS74K_INTMASK(irq), 0);
 +      else if (oldirq != 5)
-+              bcma_write32(mdev, BCMA_MIPS_MIPS74K_INTMASK(oldirq), 0);
+               bcma_write32(mdev, BCMA_MIPS_MIPS74K_INTMASK(oldirq), 0);
  
        /* assign the new one */
-       if (irq == 0) {
 @@ -123,9 +130,9 @@ static void bcma_core_mips_set_irq(struc
                            bcma_read32(mdev, BCMA_MIPS_MIPS74K_INTMASK(0)) |
                            (1 << irqflag));
  #endif /* LINUX_BCMA_REGS_H_ */
 --- a/drivers/net/wireless/b43/main.c
 +++ b/drivers/net/wireless/b43/main.c
-@@ -4656,7 +4656,7 @@ static int b43_wireless_core_init(struct
+@@ -4684,7 +4684,7 @@ static int b43_wireless_core_init(struct
        switch (dev->dev->bus_type) {
  #ifdef CONFIG_B43_BCMA
        case B43_BUS_BCMA:
index 57655aae23dc07a3fad6e75b5e70fecafde17535..c3da46c076df82265a6787fb1782d4ab6f6d1930 100644 (file)
@@ -1,6 +1,6 @@
 --- a/scripts/kallsyms.c
 +++ b/scripts/kallsyms.c
-@@ -83,6 +83,7 @@ static struct text_range text_ranges[] =
+@@ -54,6 +54,7 @@ static struct text_range text_ranges[] =
  static struct sym_entry *table;
  static unsigned int table_size, table_cnt;
  static int all_symbols = 0;
@@ -8,7 +8,7 @@
  static char symbol_prefix_char = '\0';
  
  int token_profit[0x10000];
-@@ -389,6 +390,9 @@ static void write_src(void)
+@@ -360,6 +361,9 @@ static void write_src(void)
  
        free(markers);
  
@@ -18,7 +18,7 @@
        output_label("kallsyms_token_table");
        off = 0;
        for (i = 0; i < 256; i++) {
-@@ -447,6 +451,9 @@ static void *find_token(unsigned char *s
+@@ -418,6 +422,9 @@ static void *find_token(unsigned char *s
  {
        int i;
  
@@ -28,7 +28,7 @@
        for (i = 0; i < len - 1; i++) {
                if (str[i] == token[0] && str[i+1] == token[1])
                        return &str[i];
-@@ -519,6 +526,9 @@ static void optimize_result(void)
+@@ -490,6 +497,9 @@ static void optimize_result(void)
  {
        int i, best;
  
@@ -38,7 +38,7 @@
        /* using the '\0' symbol last allows compress_symbols to use standard
         * fast string functions */
        for (i = 255; i >= 0; i--) {
-@@ -675,7 +685,9 @@ int main(int argc, char **argv)
+@@ -646,7 +656,9 @@ int main(int argc, char **argv)
                                if ((*p == '"' && *(p+2) == '"') || (*p == '\'' && *(p+2) == '\''))
                                        p++;
                                symbol_prefix_char = *p;
@@ -51,7 +51,7 @@
        } else if (argc != 1)
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1198,6 +1198,17 @@ config KALLSYMS_ALL
+@@ -1194,6 +1194,17 @@ config KALLSYMS_ALL
  
           Say N unless you really need all symbols.
  
index 77aaf8d0b5a6188461ea2e78a0851435e29be123..74ba4f0320601eb0861b714ba1e1eaa22f0c02e7 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index 1f2d0c3e480fefe5e00cb6513e683abf3da9a43a..da05f10ff4f4939303efb2fb4087619c50e96b32 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 
 DEVICE_TYPE:=developerboard
 
index f410835dddc3f6deabb7cc864d4464f5c84b3318..5670439ea8bd10a07b71ddb2f7120b24cbce8b11 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 
 include $(INCLUDE_DIR)/target.mk
 
index c202bc2570ab781ca204bd4e2c0c33dbf4c98500..36c10b315625592f405dedc2a3045ef539c9e3aa 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ppc40x/patches-3.7/001-powerpc-add-missing-NULL-terminator-to-avoid-boot-pa.patch b/target/linux/ppc40x/patches-3.7/001-powerpc-add-missing-NULL-terminator-to-avoid-boot-pa.patch
deleted file mode 100644 (file)
index fb7bf7b..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-From 107b76e67aa0447fc4ea5594823f8ffd2699fbc7 Mon Sep 17 00:00:00 2001
-From: Gabor Juhos <juhosg@openwrt.org>
-Date: Thu, 20 Dec 2012 14:22:38 +0100
-Subject: [PATCH] powerpc: add missing NULL terminator to avoid boot panic on
- PPC40x
-
-The missing NULL terminator can cause a panic on
-PPC405 boards during boot:
-
-  Linux/PowerPC load: console=ttyS0,115200 root=/dev/mtdblock1 rootfstype=squashfs,jffs2 noinitrd init=/etc/preinit
-  Finalizing device tree... flat tree at 0x6a5160
-  bootconsole [udbg0] enabled
-  Page fault in user mode with in_atomic() = 1 mm = (null)
-  NIP = c0275f50  MSR = fffffffe
-  Oops: Weird page fault, sig: 11 [#1]
-  PowerPC 40x Platform
-  Modules linked in:
-  NIP: c0275f50 LR: c0275f60 CTR: c0280000
-  REGS: c0275eb0 TRAP: 636f7265   Not tainted  (3.7.1)
-  MSR: fffffffe <VEC,VSX,EE,PR,FP,ME,SE,BE,IR,DR,PMM,RI> CR: c06a6190  XER: 00000001
-  TASK = c02662a8[0] 'swapper' THREAD: c0274000
-  GPR00: c0275ec0 c000c658 c027c4bf 00000000 c0275ee0 c000a0ec c020a1a8 c020a1f0
-  GPR08: c020f631 c020f404 c025f078 c025f080 c0275f10
-   Call Trace:
-   ---[ end trace 31fd0ba7d8756001 ]---
-
-  Kernel panic - not syncing: Attempted to kill the idle task!
-
-The panic happens since commit 9597abe00c1bab2aedce6b49866bf6d1e81c9eed
-(sections: fix section conflicts in arch/powerpc), however the root
-cause of this is that the NULL terminator were not added in commit
-a4f740cf33f7f6c164bbde3c0cdbcc77b0c4997c (of/flattree: Add of_flat_dt_match()
-helper function).
-
-Cc: Grant Likely <grant.likely@secretlab.ca>
-Cc: <stable@vger.kernel.org>
-Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
----
- arch/powerpc/platforms/40x/ppc40x_simple.c |    3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
---- a/arch/powerpc/platforms/40x/ppc40x_simple.c
-+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
-@@ -57,7 +57,8 @@ static const char * const board[] __init
-       "amcc,makalu",
-       "apm,klondike",
-       "est,hotfoot",
--      "plathome,obs600"
-+      "plathome,obs600",
-+      NULL
- };
- static int __init ppc40x_probe(void)
index cf57b79f31a48ca9262b202b1473bd1cbe183d2a..9abd715853c749b1397c134aaaf07c7872c02e53 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 
 include $(INCLUDE_DIR)/target.mk
 
index bacfcadaa5023d018cf3c3b0dfc8ce31db8838e7..82d20b6a8eb42418a2253c7ef70693d28801af50 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 88d1303488ceaae7be778edf94b85bcb355b10d1..a4f195ae4c5b203778846b2b8d9510499e9c687b 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 72ca2f3f8959ea9a8eb7acf215af7c43b78bc068..53cef2ac8b0f63ecd5c87bc201d40c2edfcbf506 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.2
+LINUX_VERSION:=3.7.3
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \