Added vpnc, a cicso3000 vpn concentrator client
authorFlorian Fainelli <florian@openwrt.org>
Tue, 13 Dec 2005 09:37:29 +0000 (09:37 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 13 Dec 2005 09:37:29 +0000 (09:37 +0000)
SVN-Revision: 2647

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/vpnc/Config.in [new file with mode: 0755]
openwrt/package/vpnc/Makefile [new file with mode: 0755]
openwrt/package/vpnc/ipkg/vpnc.control [new file with mode: 0755]
openwrt/package/vpnc/patches/01-no_man.patch [new file with mode: 0644]

index bd5bb67f88fdd5ae1548fdc4bf85df02de878a60..b8f4d6b00cef7a2e0f4182a9f4283f32bd6595e5 100644 (file)
@@ -130,6 +130,7 @@ source "package/ttcp/Config.in"
 source "package/ulogd/Config.in"
 source "package/updatedd/Config.in"
 source "package/vgp/Config.in"
+source "package/vpnc/Config.in"
 source "package/vrrpd/Config.in"
 source "package/vsftpd/Config.in"
 source "package/vtun/Config.in"
index ea902e4aac6fdff47eb98eee27ef3d43fc19052c..af04601fe2c27cc0ff6b65e0346fbb3758a2e5d9 100644 (file)
@@ -206,6 +206,7 @@ package-$(BR2_PACKAGE_USTL) += ustl
 package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
 package-$(BR2_PACKAGE_UDEV) += udev
 package-$(BR2_PACKAGE_VGP) += vgp
+package-$(BR2_PACKAGE_VPNC) += vpnc
 package-$(BR2_PACKGE_VRRPD) += vrrpd
 package-$(BR2_PACKAGE_VTUN) += vtun
 package-$(BR2_PACKAGE_VSFTPD) += vsftpd
@@ -314,6 +315,7 @@ tcpdump-compile: libpcap-compile
 tinc-compile: zlib-compile openssl-compile liblzo-compile
 tor-compile: libevent-compile openssl-compile zlib-compile
 usbutils-compile: libusb-compile
+vpnc-compile: libgcrypt-compile libgpg-error-compile
 vtun-compile: zlib-compile openssl-compile liblzo-compile
 wificonf-compile: wireless-tools-compile nvram-compile
 wknock-compile: libpcap-compile
diff --git a/openwrt/package/vpnc/Config.in b/openwrt/package/vpnc/Config.in
new file mode 100755 (executable)
index 0000000..2b3a423
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_VPNC
+       tristate "vpnc............................. client for cisco3000 VPN Concentrator."
+       default m if CONFIG_DEVEL
+       depends on BR2_PACKAGE_KMOD_TUN
+       depends on BR2_PACKAGE_LIBGPG_ERROR
+       depends on BR2_PACKAGE_LIBGCRYPT
+       help
+               Client for cisco3000 VPN Concentrator.
diff --git a/openwrt/package/vpnc/Makefile b/openwrt/package/vpnc/Makefile
new file mode 100755 (executable)
index 0000000..6aec933
--- /dev/null
@@ -0,0 +1,31 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vpnc
+PKG_VERSION:=0.3.3
+PKG_RELEASE:=1
+
+PKG_MD5SUM:=e7518cff21326fe7eb9795b60c25ae6a
+PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VPNC,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) STAGING_DIR=$(STAGING_DIR) CC=$(TARGET_CC) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install
+       touch $@
+
+$(IPKG_VPNC):
+       mkdir -p $(IDIR_VPNC)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VPNC)/
+       $(RSTRIP) $(IDIR_VPNC)
+       $(IPKG_BUILD) $(IDIR_VPNC) $(PACKAGE_DIR)
diff --git a/openwrt/package/vpnc/ipkg/vpnc.control b/openwrt/package/vpnc/ipkg/vpnc.control
new file mode 100755 (executable)
index 0000000..5087af9
--- /dev/null
@@ -0,0 +1,6 @@
+Package: vpnc
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: client for cisco3000 VPN Concentrator.
+Depends: libgpg-error libgcrypt kmod-tun
diff --git a/openwrt/package/vpnc/patches/01-no_man.patch b/openwrt/package/vpnc/patches/01-no_man.patch
new file mode 100644 (file)
index 0000000..a5cc395
--- /dev/null
@@ -0,0 +1,27 @@
+diff -urN orig/vpnc-0.3.3/Makefile vpnc-0.3.3/Makefile
+--- orig/vpnc-0.3.3/Makefile   2005-05-01 22:30:35.000000000 +0200
++++ vpnc-0.3.3/Makefile        2005-12-13 10:30:56.000000000 +0100
+@@ -22,9 +22,8 @@
+ SBINDIR=$(PREFIX)/sbin
+ MANDIR=$(PREFIX)/share/man
+-CC=gcc
+-CFLAGS=-W -Wall -O -g '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
+-LDFLAGS=-g $(shell libgcrypt-config --libs)
++CFLAGS=-W -Wall -O -I$(STAGING_DIR)/usr/include '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
++LDFLAGS=-L$(STAGING_DIR)/usr/lib $(shell libgcrypt-config --libs)
+ ifeq ($(shell uname -s), Linux)
+ SYSDEP=sysdep-linux.o
+@@ -83,10 +82,9 @@
+ all : vpnc
+ install :
+-      install -d $(DESTDIR)$(ETCDIR) $(DESTDIR)$(SBINDIR) $(DESTDIR)$(MANDIR)/man8
++      install -d $(DESTDIR)$(ETCDIR) $(DESTDIR)$(SBINDIR)
+       install vpnc.conf vpnc-script $(DESTDIR)$(ETCDIR)
+       install vpnc vpnc-disconnect $(DESTDIR)$(SBINDIR)
+-      install vpnc.8 $(DESTDIR)$(MANDIR)/man8
+ install-strip :
+       install -d $(DESTDIR)$(ETCDIR) $(DESTDIR)$(SBINDIR) $(DESTDIR)$(MANDIR)/man8