uhttpd: fix possible CGI header line parsing beyound the empty line, thanks Linus...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Sep 2011 22:30:20 +0000 (22:30 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Sep 2011 22:30:20 +0000 (22:30 +0000)
SVN-Revision: 28254

package/uhttpd/Makefile
package/uhttpd/src/uhttpd-cgi.c

index 5fa12fc8bcddf92fb5bacbecf4a4f4224b2747dc..4f292848836bc13d17ac4bfcde7b5ed5eab18951 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=26
+PKG_RELEASE:=27
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index ed688514c40e0c026591f4beb712c481e3e84698..2f94fe26f58f65f66e1d223b18642b30ae9d37bd 100644 (file)
@@ -1,7 +1,7 @@
 /*
  * uhttpd - Tiny single-threaded httpd - CGI handler
  *
- *   Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+ *   Copyright (C) 2010-2011 Jo-Philipp Wich <xm@subsignal.org>
  *
  *  Licensed under the Apache License, Version 2.0 (the "License");
  *  you may not use this file except in compliance with the License.
@@ -42,7 +42,7 @@ static struct http_response * uh_cgi_header_parse(char *buf, int len, int *off)
 
                bufptr = &buf[0];
 
-               for( pos = 0; pos < len; pos++ )
+               for( pos = 0; pos < off; pos++ )
                {
                        if( !hdrname && (buf[pos] == ':') )
                        {
@@ -60,11 +60,11 @@ static struct http_response * uh_cgi_header_parse(char *buf, int len, int *off)
 
                        else if( (buf[pos] == '\r') || (buf[pos] == '\n') )
                        {
-                               buf[pos++] = 0;
-
                                if( ! hdrname )
                                        break;
 
+                               buf[pos++] = 0;
+
                                if( (pos < len) && (buf[pos] == '\n') )
                                        pos++;