kernel/modules: add chaoskey module, hardware TRNG
authorHannu Nyman <hannu.nyman@iki.fi>
Sun, 17 Jun 2018 17:54:41 +0000 (20:54 +0300)
committerJohn Crispin <john@phrozen.org>
Mon, 18 Jun 2018 18:29:38 +0000 (20:29 +0200)
Package the driver for Chaoskey, a USB dongle that provides a
True Random Number Generator (TRNG) and feeds entropy to kernel.

Chaoskey driver is included the upstream Linux sources, so
only packaging it is needed.

Run-tested with ipq806x/R7800 and mvebu/WRT3200ACM.

(Requires CONFIG_HW_RANDOM kernel option.)

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
package/kernel/linux/modules/usb.mk

index 5e10f9eab5eb2a79bcdd20d425b03d645677fa50..2cf48e468f14f11122b771e36c7aae3078cdf6f9 100644 (file)
@@ -1639,3 +1639,18 @@ endef
 
 $(eval $(call KernelPackage,usb-net2280))
 
+define KernelPackage/chaoskey
+  SUBMENU:=$(USB_MENU)
+  TITLE:=Chaoskey hardware RNG support
+  KCONFIG:=CONFIG_USB_CHAOSKEY
+  FILES:=$(LINUX_DIR)/drivers/usb/misc/chaoskey.ko
+  AUTOLOAD:=$(call AutoProbe,chaoskey)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/chaoskey/description
+  Kernel module for chaoskey, USB attached true random number generator
+endef
+
+$(eval $(call KernelPackage,chaoskey))
+