add support for config options checking in top-level directory stampfiles
authorFelix Fietkau <nbd@openwrt.org>
Mon, 6 Apr 2009 09:56:16 +0000 (09:56 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 6 Apr 2009 09:56:16 +0000 (09:56 +0000)
SVN-Revision: 15112

include/subdir.mk

index 40e31923bc27853d6200cb1672b38caa92dfeef3..d4076e6c47e8ea5186acdc13ba228711c7a6eb32 100644 (file)
@@ -46,9 +46,9 @@ define subdir
   $(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
 endef
 
-# Parameters: <subdir> <name> <target> <depends>
+# Parameters: <subdir> <name> <target> <depends> <config options>
 define stampfile
-  $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
+  $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
   $$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
        @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
                $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)