ramips: add dwr-512 jboot firmware configuration
authorGiuseppe Lippolis <giu.lippolis@gmail.com>
Thu, 5 Apr 2018 16:01:41 +0000 (18:01 +0200)
committerMathias Kresin <dev@kresin.me>
Sun, 8 Apr 2018 07:51:06 +0000 (09:51 +0200)
The previous fw version require the replacement of the stock bootloader
with u-boot. This prevent an easy stock restore of the original fw.

Now a proper fw util has been developed to manage the stock jboot
bootloader. Therefore make sense have a fw image for the stock
bootloader.

The old fw configuration (u-boot) is not compatible with the new one
and will not be supported anymore.

So at the end 2 image can be generated:

1) factory image with jboot bootloader
     openwrt-ramips-rt305x-dwr-512-b-squashfs-factory.bin
2) sysupgrade image with jboot bootloader
     openwrt-ramips-rt305x-dwr-512-b-squashfs-sysupgrade.bin

Signed-off-by: Giuseppe Lippolis <giu.lippolis@gmail.com>
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/DWR-512-B.dts
target/linux/ramips/image/rt305x.mk
target/linux/ramips/rt305x/config-4.14
target/linux/ramips/rt3883/config-4.14

index 44be484374f56a2e0fe729a49f9fc111cc6efc2b..c58102cf4e96b3548045d62d3f18d2bc44ca1065 100755 (executable)
@@ -52,7 +52,6 @@ platform_check_image() {
        dir-620-d1|\
        dir-810l|\
        duzun-dm06|\
-       dwr-512-b|\
        e1700|\
        esr-9753|\
        ew1200|\
@@ -272,7 +271,8 @@ platform_check_image() {
                return 0
                ;;
        dlink,dwr-116-a1|\
-       dlink,dwr-921-c1)
+       dlink,dwr-921-c1|\
+       dwr-512-b)
                [ "$magic" != "0404242b" ] && {
                        echo "Invalid image type."
                        return 1
index afcac21c6c9a64657b17f8b6f7c2808340670822..74a33e10e4fc347e114114b25e8a82071874b61d 100644 (file)
                m25p,fast-read;
 
                partition@0 {
-                       label = "u-boot";
-                       reg = <0x0 0x30000>;
+                       label = "jboot";
+                       reg = <0x0 0x10000>;
                        read-only;
                };
 
-               partition@30000 {
-                       label = "u-boot-env";
-                       reg = <0x30000 0x20000>;
-                       read-only;
-               };
-
-               partition@50000 {
+               partition@10000 {
                        label = "firmware";
-                       reg = <0x50000 0x7a0000>;
+                       reg = <0x10000 0x7e0000>;
                };
 
                config: partition@7f0000 {
index dbf15bc7d7f2abda363a4d87b7f1ef78bd7b9b87..5a4ca73517c0096640e20ec7ca1d6ac7b1ca8845 100644 (file)
@@ -302,10 +302,18 @@ TARGET_DEVICES += dir-620-d1
 
 define Device/dwr-512-b
   DTS := DWR-512-B
-  IMAGE_SIZE := 7700k
+  IMAGE_SIZE := 7800k
   DEVICE_TITLE := D-Link DWR-512 B
-  DEVICE_PACKAGES := kmod-usb2 kmod-spi-dev kmod-usb-serial kmod-usb-serial-option \
-                       kmod-usb-net kmod-usb-net-cdc-ether comgt-ncm
+  DEVICE_PACKAGES := jboot-tools kmod-usb2 kmod-spi-dev kmod-usb-serial \
+                       kmod-usb-serial-option kmod-usb-net kmod-usb-net-cdc-ether \
+                       comgt-ncm
+  DLINK_ROM_ID := DLK6E2412001
+  DLINK_FAMILY_MEMBER := 0x6E24
+  DLINK_FIRMWARE_SIZE := 0x7E0000
+  KERNEL := $(KERNEL_DTB)
+  IMAGES += factory.bin
+  IMAGE/sysupgrade.bin := mkdlinkfw | pad-rootfs | append-metadata
+  IMAGE/factory.bin := mkdlinkfw | pad-rootfs | mkdlinkfw-factory
 endef
 TARGET_DEVICES += dwr-512-b
 
index 33be3910a921af39dbf8f03250bdac0368e3fbce..dadf88e0322fa4b1035d85634e93c94920fce2e3 100644 (file)
@@ -138,6 +138,7 @@ CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_SPI_NOR_USE_4K_SECTORS=y
 CONFIG_MTD_SPI_NOR_USE_4K_SECTORS_LIMIT=16384
 CONFIG_MTD_SPLIT_FIRMWARE=y
+CONFIG_MTD_SPLIT_JIMAGE_FW=y
 CONFIG_MTD_SPLIT_SEAMA_FW=y
 CONFIG_MTD_SPLIT_UIMAGE_FW=y
 CONFIG_NEED_DMA_MAP_STATE=y
index 6a0386fa47985c26b09cbb706dbd10d5cc9404dc..0c0a840c39ca00423a4ae79fde575a1a3087ee70 100644 (file)
@@ -158,6 +158,7 @@ CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_SPI_NOR_USE_4K_SECTORS=y
 CONFIG_MTD_SPI_NOR_USE_4K_SECTORS_LIMIT=16384
 CONFIG_MTD_SPLIT_FIRMWARE=y
+CONFIG_MTD_SPLIT_JIMAGE_FW=y
 CONFIG_MTD_SPLIT_SEAMA_FW=y
 CONFIG_MTD_SPLIT_UIMAGE_FW=y
 CONFIG_NEED_DMA_MAP_STATE=y