Enable profiles for adm5120
authorFlorian Fainelli <florian@openwrt.org>
Wed, 21 Mar 2007 18:10:55 +0000 (18:10 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 21 Mar 2007 18:10:55 +0000 (18:10 +0000)
SVN-Revision: 6629

target/linux/adm5120-2.6/profiles/100-Atheros.mk [new file with mode: 0644]
target/linux/adm5120-2.6/profiles/110-None.mk [new file with mode: 0644]

diff --git a/target/linux/adm5120-2.6/profiles/100-Atheros.mk b/target/linux/adm5120-2.6/profiles/100-Atheros.mk
new file mode 100644 (file)
index 0000000..0295868
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/adm5120-2.6/profiles/110-None.mk b/target/linux/adm5120-2.6/profiles/110-None.mk
new file mode 100644 (file)
index 0000000..2fcfacd
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+  NAME:=No WiFi
+  PACKAGES:=
+endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+