build: add CHECK_ALL variable to allow make download/check to include not selected...
authorFelix Fietkau <nbd@nbd.name>
Fri, 16 Dec 2016 15:08:44 +0000 (16:08 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sat, 17 Dec 2016 09:36:52 +0000 (10:36 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/Makefile
tools/Makefile

index c4fb8ca97450e499304910badafe73243af78a56..64efeb374588e64e960c2df8fb275523c4c92822 100644 (file)
@@ -14,6 +14,10 @@ $(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
 $(curdir)/builddirs-install:=.
 $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
 $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
+ifdef CHECK_ALL
+$(curdir)/builddirs-check:=$($(curdir)/builddirs)
+$(curdir)/builddirs-download:=$($(curdir)/builddirs)
+endif
 ifneq ($(IGNORE_ERRORS),)
   package-y-filter := $(package-y)
   package-m-filter := $(filter-out $(package-y),$(package-m))
index 6915ea7a05552dc73500f20a110fad8a6ddbb1f1..247f55776f81e4b4cfb9029623e23cd6e9ab23e2 100644 (file)
@@ -110,6 +110,11 @@ tools-y += flock
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
 
+ifdef CHECK_ALL
+$(curdir)/builddirs-check:=$($(curdir)/builddirs)
+$(curdir)/builddirs-download:=$($(curdir)/builddirs)
+endif
+
 ifndef DUMP_TARGET_DB
 define PrepareStaging
        @for dir in $(1); do ( \