kernel: add rtl8723au driver (staging)
authorJohn Crispin <john@openwrt.org>
Thu, 9 Apr 2015 10:33:16 +0000 (10:33 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 9 Apr 2015 10:33:16 +0000 (10:33 +0000)
- move config symbol to separate package (Why was it there in the first place?)
- 8723au might be used in some USB sticks or on some sunxi boards

compile tested only

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 45336

package/kernel/linux/modules/wireless.mk

index 30ba0a87c231192a95a950f91926f19ceb6dd28a..086a401ecc9e401aba6a37d3c4b7abd2b89055a0 100644 (file)
@@ -114,7 +114,6 @@ define KernelPackage/net-rtl8188eu
   KCONFIG:=\
        CONFIG_STAGING=y \
        CONFIG_R8188EU \
-       CONFIG_R8723AU \
        CONFIG_88EU_AP_MODE=y \
        CONFIG_88EU_P2P=n
   FILES:=$(LINUX_DIR)/drivers/staging/rtl8188eu/r8188eu.ko
@@ -127,6 +126,27 @@ endef
 
 $(eval $(call KernelPackage,net-rtl8188eu))
 
+
+define KernelPackage/net-rtl8723au
+  SUBMENU:=$(WIRELESS_MENU)
+  TITLE:=RTL8723AU support (staging)
+  DEPENDS:=@!LINUX_3_10 @USB_SUPPORT +@DRIVER_WEXT_SUPPORT +r8188eu-firmware +kmod-usb-core
+  KCONFIG:=\
+        CONFIG_STAGING=y \
+        CONFIG_R8723AU \
+        CONFIG_8723AU_AP_MODE=y \
+        CONFIG_8723AU_BT_COEXIST=y
+  FILES:=$(LINUX_DIR)/drivers/staging/rtl8723au/r8723au.ko
+  AUTOLOAD:=$(call AutoProbe,r8723au)
+endef
+
+define KernelPackage/net-rtl8723au/description
+ Kernel modules for RealTek RTL8723AU support
+endef
+
+$(eval $(call KernelPackage,net-rtl8723au))
+
+
 define KernelPackage/net-rtl8192su
   SUBMENU:=$(WIRELESS_MENU)
   TITLE:=RTL8192SU support (staging)