openssl: add support for RIPEMD/160
authorFelix Fietkau <nbd@openwrt.org>
Thu, 14 Nov 2013 20:42:15 +0000 (20:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 14 Nov 2013 20:42:15 +0000 (20:42 +0000)
RIPEMD is needed to update erlang and i'd like to enable RIPEMD160 support in openssh.

Size compared:

openssl without RIPEMD/160 support:
647K 29. Okt 20:00 bin/ar71xx/packages/libopenssl_1.0.1e-2_ar71xx.ipk

openssl with RIPEMD/160 support:
652K  8. Nov 15:11 bin/ar71xx/packages/libopenssl_1.0.1e-2_ar71xx.ipk

So the file size just grows ~5kb, which shouldn't be a problem.

Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 38809

package/libs/openssl/Makefile

index a280ff419cc63b7220de811148a77f18cf6cd0ee..27b6e99e3bfcccc52b037455019c4490717e3347 100644 (file)
@@ -78,7 +78,7 @@ endef
 
 
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
-       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+       no-aes192 no-camellia no-ans1 no-krb5
 OPENSSL_OPTIONS:= shared no-err no-hw no-threads zlib-dynamic no-sse2
 
 ifdef CONFIG_OPENSSL_ENGINE_CRYPTO