toolchain: Broaden the executable loader pattern
authorFlorian Fainelli <f.fainelli@gmail.com>
Sun, 1 Jan 2017 00:13:35 +0000 (16:13 -0800)
committerFlorian Fainelli <f.fainelli@gmail.com>
Sun, 29 Jan 2017 19:51:02 +0000 (11:51 -0800)
Some toolchains will produce executables with an interpreter that is e.g:
ld.so.1 (typically a symbolic link). Due to our current LIBC_SPEC_FILE value,
we would not be able to copy this symbolic link/file over to the rootfs and
executables would fail to load. Extend the search pattern to include all
ld*.so* files that could be needed.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/libs/toolchain/Makefile

index 0101b81a318b51680d6078ca703f492fa1a76093..4822ca7be3ba722b174811a5b615052e5f66f1c0 100644 (file)
@@ -164,7 +164,7 @@ define Package/libc/config
                string
                prompt "libc shared library files (use wildcards)"
                depends on EXTERNAL_TOOLCHAIN && PACKAGE_libc
-               default "./lib/ld{-*.so,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*}"
+               default "./lib/ld{*.so*,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*}"
 
        endmenu
 endef