mac80211: fix 5ghz variable name
authorImre Kaloz <kaloz@openwrt.org>
Fri, 20 Mar 2015 12:13:11 +0000 (12:13 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 20 Mar 2015 12:13:11 +0000 (12:13 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 44907

package/kernel/mac80211/Makefile
package/kernel/mac80211/files/lib/wifi/mac80211.sh

index d71417ec35edcd94524881ecf64ee8fca04132d5..c7d7c1e76f09443140dafd7fc148ec9850090332 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=2015-03-09
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 PKG_BACKPORT_VERSION:=
 PKG_MD5SUM:=6d4b04e4ce8a1f54dabfb04f4709453c
index ff0d467ab15eb580423b050fc7b589b412e705da..ea229d6c03393d4673c733c99ead4c24ff92817d 100644 (file)
@@ -86,8 +86,8 @@ detect_mac80211() {
                iw phy "$dev" info | grep -q '2412 MHz' || { mode_band="a"; channel="36"; }
 
                vht_cap=$(iw phy "$dev" info | grep -c 'VHT Capabilities')
-               5ghz_cap=$(iw phy "$dev" info | grep -c "Band 2")
-               [ "$vht_cap" -gt 0 -a "$5ghz_cap" -gt 0 ] && {
+               cap_5ghz=$(iw phy "$dev" info | grep -c "Band 2")
+               [ "$vht_cap" -gt 0 -a "$cap_5ghz" -gt 0 ] && {
                        mode_band="a";
                        channel="36"
                        htmode="VHT80"