ramips: add support for Widora Neo 32MB flash revision
authorJackson Ming Hu <huming2207@gmail.com>
Mon, 8 Jan 2018 05:27:28 +0000 (13:27 +0800)
committerMathias Kresin <dev@kresin.me>
Tue, 23 Jan 2018 22:31:09 +0000 (23:31 +0100)
Widora has updated their Widora Neo board recently.

The new model uses 32MB WSON-8 factor SPI flash
instead of the original 16MB SOP-8 factor SPI flash.

All the other hardware components are the same as
the first revision.

Detailed hardware specs listed below:

CPU: MTK MT7688AN
RAM: 128MB DDR2
ROM: 32MB WSON-8 factor SPI Flash (Winbond)
WiFi: Built-in 802.11n 150Mbps?
Ethernet: 10/100Mbps x1
Audio codec: WM8960
Other IO: USB OTG;
  USB Power+Serial (CP2104);
  3x LEDs (Power, LAN, WiFi);
  2x Keys (WPS, CPU Reset)
  1x Audio In/Out
  1x IPEX antenna port
  1x Micro SD slot

Signed-off-by: Jackson Ming Hu <huming2207@gmail.com>
Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WIDORA-NEO-32M.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk

index 53d885560b355a6805454d875ae358eadb8c2e0d..705532753d22efbaa2229af31ba44f43030a126a 100755 (executable)
@@ -58,6 +58,7 @@ ramips_setup_interfaces()
        timecloud|\
        w150m|\
        widora,neo-16m|\
+       widora,neo-32m|\
        wnce2001|\
        zbt-cpe102|\
        zte-q7)
index f08e8e1c17cb71426c07aec61880d709b5413848..dadb1bb6f6b2ef10f2b7f099a0b18c7260b3bd4b 100644 (file)
@@ -285,7 +285,8 @@ get_status_led() {
        zbt-we2026)
                status_led="$boardname:red:power"
                ;;
-       widora,neo-16m)
+       widora,neo-16m|\
+       widora,neo-32m)
                status_led="widora:orange:wifi"
                ;;
        wzr-agl300nh)
index 6374e3d1e70c154c35bd4c4d0278b65aa2456162..dd7616034bcc11c35178ff77a4b31a5e1b994e58 100755 (executable)
@@ -168,6 +168,7 @@ platform_check_image() {
        whr-600d|\
        whr-g300n|\
        widora,neo-16m|\
+       widora,neo-32m|\
        witi|\
        wizfi630a|\
        wl-330n|\
diff --git a/target/linux/ramips/dts/WIDORA-NEO-32M.dts b/target/linux/ramips/dts/WIDORA-NEO-32M.dts
new file mode 100644 (file)
index 0000000..591101e
--- /dev/null
@@ -0,0 +1,54 @@
+/dts-v1/;
+
+#include "WIDORA-NEO.dtsi"
+
+/ {
+       compatible = "widora,neo-32m", "widora,neo", "mediatek,mt7628an-soc";
+       model = "Widora-NEO (32M)";
+};
+
+&spi0 {
+       status = "okay";
+
+       pinctrl-names = "default";
+       pinctrl-0 = <&spi_pins>, <&spi_cs1_pins>;
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <40000000>;
+               m25p,chunked-io = <31>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x1fb0000>;
+               };
+       };
+
+       spidev@1 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "linux,spidev";
+               reg = <1>;
+               spi-max-frequency = <40000000>;
+       };
+};
index 6c0102fc92495b9f41792756158d2d4403a7c2b0..f58a2208c17e73b418ef65551a62df9d5de1a6ad 100644 (file)
@@ -224,6 +224,14 @@ define Device/widora_neo-16m
 endef
 TARGET_DEVICES += widora_neo-16m
 
+define Device/widora_neo-32m
+  DTS := WIDORA-NEO-32M
+  IMAGE_SIZE := $(ralink_default_fw_size_32M)
+  DEVICE_TITLE := Widora-NEO (32M)
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += widora_neo-32m
+
 define Device/wrtnode2p
   DTS := WRTNODE2P
   IMAGE_SIZE := $(ralink_default_fw_size_16M)