ramips: Add support for TEW-714TRU
authorJimmy Zhong <mb300sd@mb300sd.net>
Wed, 3 Aug 2016 17:58:01 +0000 (13:58 -0400)
committerJohn Crispin <john@phrozen.org>
Wed, 10 Aug 2016 01:03:50 +0000 (03:03 +0200)
Signed-off-by: Jimmy Zhong <mb300sd@mb300sd.net>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/TEW-714TRU.dts [new file with mode: 0644]
target/linux/ramips/image/rt305x.mk

index 9624b1c64aff0a26408c2c7a0844be2e6175f89f..97c405d3fd07d7a6dc8c94fccf3cda4eeefcd557 100755 (executable)
@@ -269,6 +269,10 @@ rt-n14u)
        set_wifi_led "$board:blue:air"
        set_usb_led "$board:blue:usb"
        ;;
+tew-714tru)
+       set_usb_led "$board:red:usb"
+       set_wifi_led "$board:green:wifi"
+       ;;
 tiny-ac)
        set_wifi_led "$board:orange:wifi"
        set_usb_led "$board:green:usb"
index a404af9fbc1023c042bf289a42c0f57f0d151631..6aba1b0b1d9e735abf3a6b8bc3783dbba9af8141 100755 (executable)
@@ -212,6 +212,7 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "0@eth0"
                ;;
+       tew-714tru|\
        v11st-fe|\
        wzr-agl300nh)
                ucidef_add_switch "switch0" \
index 565d5138cb264fb1b554610eea9f880305e5defb..1ea4fb2d719b3eea310030430c5c1b5f994dd98b 100755 (executable)
@@ -403,6 +403,9 @@ ramips_board_detect() {
        *"TEW-692GR")
                name="tew-692gr"
                ;;
+       *"TEW-714TRU")
+               name="tew-714tru"
+               ;;
        *"UBNT-ERX")
                name="ubnt-erx"
                ;;
index 88547ca0833b2466b62d7f6f17e57250c99e4496..d9adf184d44bba169ff74dc0c9350bbf090e8e8e 100755 (executable)
@@ -118,6 +118,7 @@ platform_check_image() {
        sl-r7205|\
        tew-691gr|\
        tew-692gr|\
+       tew-714tru|\
        tiny-ac|\
        ur-326n4g|\
        ur-336un|\
diff --git a/target/linux/ramips/dts/TEW-714TRU.dts b/target/linux/ramips/dts/TEW-714TRU.dts
new file mode 100644 (file)
index 0000000..0e0f066
--- /dev/null
@@ -0,0 +1,122 @@
+/dts-v1/;
+
+#include "rt5350.dtsi"
+
+/ {
+       compatible = "TEW-714TRU", "ralink,rt5350-soc";
+       model = "TRENDnet TEW714TRU";
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               usb {
+                       label = "tew-714tru:red:usb";
+                       gpios = <&gpio0 9 1>;
+               };
+
+               wifi {
+                       label = "tew-714tru:green:wifi";
+                       gpios = <&gpio0 13 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+                reset {
+                        label = "reset";
+                        gpios = <&gpio0 10 1>;
+                        linux,code = <0x198>;
+                };
+
+                wps {
+                        label = "wps";
+                        gpios = <&gpio0 0 1>;
+                        linux,code = <0x211>;
+                };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               repeater {
+                       gpio-export,name = "repeater_switch";
+                       gpios = <&gpio0 7 0>;
+               };
+
+               wisp {
+                       gpio-export,name = "wisp_switch";
+                       gpios = <&gpio0 12 0>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               linux,modalias = "m25p80", "s25fl064k";
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x7b0000>;
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "i2c", "jtag", "uartf";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4>;
+};
+
+&esw {
+       mediatek,portmap = <0x1>;
+       mediatek,portdisable = <0x3e>;
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0>;
+};
+
+&ehci {
+       status = "okay";
+};
+
+&ohci {
+       status = "okay";
+};
index 8b08cc2981bce814ab197fbbbeaa900fcf461a91..82e77da68235f4a457226f3f0b38bb3805072989 100644 (file)
@@ -418,6 +418,12 @@ define Device/sl-r7205
 endef
 TARGET_DEVICES += sl-r7205
 
+define Device/tew-714tru
+  DTS := TEW-714TRU
+  IMAGE_SIZE := $(ralink_default_fw_size_8M)
+  DEVICE_TITLE := TRENDnet TEW-714TRU
+endef
+TARGET_DEVICES += tew-714tru
 
 define Device/v22rw-2x2
   DTS := V22RW-2X2