procd: support term_timeout parameter
authorJo-Philipp Wich <jo@mein.io>
Tue, 20 Jun 2017 11:44:10 +0000 (13:44 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 26 Jun 2017 08:02:20 +0000 (10:02 +0200)
Expose "term_timeout" parameter in procd.sh to allow init scripts to
request a longer termination timeout.

This is required to fix FS#859 in a later commit.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/system/procd/Makefile
package/system/procd/files/procd.sh

index 8b987aabaf55620121ae8bbe75ab707ab437d140..5f4c3a6713371bf34a713b8922768fa9ea4a789b 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(LEDE_GIT)/project/procd.git
index 9fbf47e602af619007ec2b958f40b0b0ab29116f..00d754d16ff0321ab46519a5f566fd966f69b508 100644 (file)
@@ -213,7 +213,7 @@ _procd_set_param() {
                        json_add_string "" "$@"
                        json_close_array
                ;;
-               nice)
+               nice|term_timeout)
                        json_add_int "$type" "$1"
                ;;
                reload_signal)