hostapd: start hostapd/wpa_supplicant for all wiphy devices
authorPiotr Dymacz <pepe2k@gmail.com>
Mon, 20 Jan 2020 18:35:01 +0000 (19:35 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Mon, 24 Feb 2020 22:27:50 +0000 (23:27 +0100)
c888e17e06 ("hostapd: manage instances via procd instead of pidfile")
added procd support for managing hostapd and wpa_supplicant daemons
but at the same time limited wiphy names to 'phy*'.

This brings back initial behaviour (introduced in 60fb4c92b6 ("hostapd:
add ubus reload") and makes procd manage daemons for any wiphy device
found in '/sys/class/ieee80211'.

CC: Felix Fietkau <nbd@nbd.name>
CC: Daniel Golle <daniel@makrotopia.org>
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.hotplug

index d4e3115bf7cb1383c57d3fa8fd24648fb8075625..1deab4405833be72b85513969eedde223543619c 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index c319d42c1a6e17154b11af804fb0ba6767abace0..2c936fde7515cfdbb64de336df25643186e0fe29 100644 (file)
@@ -21,7 +21,7 @@ service_data() {
 
 procd_open_service hostapd
 
 
 procd_open_service hostapd
 
-for phy in phy*; do
+for phy in *; do
        [ -d "$phy" ] || continue
 
        mkdir -p /var/run/wpa_supplicant-$phy /var/run/hostapd-$phy
        [ -d "$phy" ] || continue
 
        mkdir -p /var/run/wpa_supplicant-$phy /var/run/hostapd-$phy