tools/pkg-config: update to 0.29
authorFelix Fietkau <nbd@openwrt.org>
Fri, 30 Oct 2015 22:31:29 +0000 (22:31 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 30 Oct 2015 22:31:29 +0000 (22:31 +0000)
Release announcement:
http://lists.freedesktop.org/archives/pkg-config/2015-September/001019.html

Drop patches, as they have been implemented upstream.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Signed-off-by: Felix Fietkau <nbd@openwrt.org> [fix OSX compatibility]
SVN-Revision: 47300

tools/pkg-config/Makefile
tools/pkg-config/patches/001-fix-package-rebuild.patch [deleted file]
tools/pkg-config/patches/002-musl_host_fixup.patch [deleted file]

index 9a1b3fb9869775c31996ac828f90ec4c2d6fc467..40e6e083e887a0d373c36962c54fe36214947cb1 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pkg-config
-PKG_VERSION:=0.28
+PKG_VERSION:=0.29
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
-PKG_MD5SUM:=aa3c86e67551adc3ac865160e34a2a0d
+PKG_MD5SUM:=77f27dce7ef88d0634d0d6f90e03a77f
 
 HOST_BUILD_PARALLEL:=1
 
@@ -21,6 +21,10 @@ unexport PKG_CONFIG
 
 HOST_CONFIGURE_ARGS += --with-internal-glib
 
+ifeq ($(HOST_OS),Darwin)
+HOST_LDFLAGS += -framework CoreFoundation -framework Carbon
+endif
+
 define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install
        mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
diff --git a/tools/pkg-config/patches/001-fix-package-rebuild.patch b/tools/pkg-config/patches/001-fix-package-rebuild.patch
deleted file mode 100644 (file)
index 54f549c..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -39,7 +39,7 @@
- if HOST_TOOL
- host_tool = $(host)-pkg-config$(EXEEXT)
- install-exec-hook:
--      cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
-+      cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
- uninstall-hook:
-       cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
- endif
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -1093,7 +1093,7 @@
-       uninstall-man1
- @HOST_TOOL_TRUE@install-exec-hook:
--@HOST_TOOL_TRUE@      cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
-+@HOST_TOOL_TRUE@      cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
- @HOST_TOOL_TRUE@uninstall-hook:
- @HOST_TOOL_TRUE@      cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
diff --git a/tools/pkg-config/patches/002-musl_host_fixup.patch b/tools/pkg-config/patches/002-musl_host_fixup.patch
deleted file mode 100644 (file)
index d39a738..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/glib/config.sub
-+++ b/glib/config.sub
-@@ -122,9 +122,9 @@ esac
- # Here we must recognize all the valid KERNEL-OS combinations.
- maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
- case $maybe_os in
--  nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-newlib* | \
--  linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
--  knetbsd*-gnu* | netbsd*-gnu* | \
-+  nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-musl* | \
-+  linux-newlib* | linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | \
-+  kfreebsd*-gnu* | knetbsd*-gnu* | netbsd*-gnu* | \
-   kopensolaris*-gnu* | \
-   storm-chaos* | os2-emx* | rtmk-nova*)
-     os=-$maybe_os
-@@ -1354,7 +1354,7 @@ case $os in
-             | -chorusos* | -chorusrdb* | -cegcc* \
-             | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
-             | -mingw32* | -linux-gnu* | -linux-android* \
--            | -linux-newlib* | -linux-uclibc* \
-+            | -linux-musl* | -linux-newlib* | -linux-uclibc* \
-             | -uxpv* | -beos* | -mpeix* | -udk* \
-             | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
-             | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \