mac80211: fix build of rtw88
authorDavid Bauer <mail@david-bauer.net>
Tue, 22 Oct 2019 13:16:41 +0000 (15:16 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 22 Oct 2019 13:16:41 +0000 (15:16 +0200)
This commit fixes failing builds because of an incorrect configuration
for the kmod-rtw88 package.

RTW88_8822BE as well as RTW88_8822CE have to bes selected as "y" even
when building the driver as a module.

Signed-off-by: David Bauer <mail@david-bauer.net>
package/kernel/mac80211/realtek.mk

index b3e19a9428e9e1751beb0ae0cddd36a445dd2ec7..41f5e3e9dc5f7b415f47c96c173ace094008d253 100644 (file)
@@ -22,7 +22,8 @@ config-$(CONFIG_PACKAGE_RTLWIFI_DEBUG) += RTLWIFI_DEBUG
 config-$(call config_package,rtl8xxxu) += RTL8XXXU
 config-y += RTL8XXXU_UNTESTED
 
-config-$(call config_package,rtw88) += RTW88 RTW88_CORE RTW88_PCI RTW88_8822BE RTW88_8822CE
+config-$(call config_package,rtw88) += RTW88 RTW88_CORE RTW88_PCI
+config-y += RTW88_8822BE RTW88_8822CE
 
 define KernelPackage/rtl818x/Default
   $(call KernelPackage/mac80211/Default)