mvebu: add the Armada 385 Reference Design support
authorImre Kaloz <kaloz@openwrt.org>
Thu, 5 Feb 2015 11:29:56 +0000 (11:29 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 5 Feb 2015 11:29:56 +0000 (11:29 +0000)
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 44265

target/linux/mvebu/image/Makefile
target/linux/mvebu/patches-3.18/207-armada-385-rd-mtd-partitions.patch [new file with mode: 0644]
target/linux/mvebu/patches-3.19/207-armada-385-rd-mtd-partitions.patch [new file with mode: 0644]

index c8ec72e87ce388211830b07e3e6728235ecdc5e6..19d7069b6783a5f4edf67e8fc39663e2161d8d5c 100644 (file)
@@ -138,6 +138,9 @@ $(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512))
 # Boards with large NOR, where we want to use UBI
 $(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
 
+# Boards with small NOR, where UBI doesn't make sense
+$(eval $(call NORProfile,385-RD,armada-385-rd,256KiB))
+
 define Image/Build/Profile/Mamba/squashfs
        $(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512)
        ( \
diff --git a/target/linux/mvebu/patches-3.18/207-armada-385-rd-mtd-partitions.patch b/target/linux/mvebu/patches-3.18/207-armada-385-rd-mtd-partitions.patch
new file mode 100644 (file)
index 0000000..80cec30
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/arch/arm/boot/dts/armada-385-rd.dts
++++ b/arch/arm/boot/dts/armada-385-rd.dts
+@@ -42,6 +42,16 @@
+                                       compatible = "st,m25p128";
+                                       reg = <0>; /* Chip select 0 */
+                                       spi-max-frequency = <108000000>;
++
++                                      partition@0 {
++                                              label = "uboot";
++                                              reg = <0 0x400000>;
++                                      };
++
++                                      partition@1 {
++                                              label = "firmware";
++                                              reg = <0x400000 0xc00000>;
++                                      };
+                               };
+                       };
diff --git a/target/linux/mvebu/patches-3.19/207-armada-385-rd-mtd-partitions.patch b/target/linux/mvebu/patches-3.19/207-armada-385-rd-mtd-partitions.patch
new file mode 100644 (file)
index 0000000..80cec30
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/arch/arm/boot/dts/armada-385-rd.dts
++++ b/arch/arm/boot/dts/armada-385-rd.dts
+@@ -42,6 +42,16 @@
+                                       compatible = "st,m25p128";
+                                       reg = <0>; /* Chip select 0 */
+                                       spi-max-frequency = <108000000>;
++
++                                      partition@0 {
++                                              label = "uboot";
++                                              reg = <0 0x400000>;
++                                      };
++
++                                      partition@1 {
++                                              label = "firmware";
++                                              reg = <0x400000 0xc00000>;
++                                      };
+                               };
+                       };