lldpd: make LLDP-MED, DOT1 and DOT3 extensions disable-able
authorJohn Crispin <john@openwrt.org>
Fri, 13 Mar 2015 08:38:25 +0000 (08:38 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 13 Mar 2015 08:38:25 +0000 (08:38 +0000)
The names for the config options were taken from lldpd's
configure.ac file.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
SVN-Revision: 44743

package/network/services/lldpd/Config.in
package/network/services/lldpd/Makefile

index c7d47953af34c261b2d607046909521a704b97fe..a416490425eab524ffadddb74e34b89b09323164 100644 (file)
@@ -21,8 +21,24 @@ config LLDPD_WITH_SONMP
        default y
        prompt "Enable support for the SynOptics Network Management Protocol"
 
+config LLDPD_WITH_LLDPMED
+       bool
+       prompt "Enable LLDP-MED extension"
+       default y
+
+config LLDPD_WITH_DOT1
+       bool
+       prompt "Enable Dot1 extension (VLAN stuff)"
+       default y
+
+config LLDPD_WITH_DOT3
+       bool
+       prompt "Enable Dot3 extension (PHY stuff)"
+       default y
+
 config LLDPD_WITH_JSON
        bool
        prompt "Enable JSON output for the LLDP Command-Line Interface"
        default n
+
 endmenu
index 5a1921e9d0b6b5432b42da705ca396f1182abbf3..6f97f45e65b3112b35f8f4bfcb5c7c687afe6db6 100644 (file)
@@ -85,6 +85,9 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
        $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
        $(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
+       $(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
+       $(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
+       $(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
        $(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
        $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)