cosmetic & coherency fixes
authorNicolas Thill <nico@openwrt.org>
Tue, 3 Feb 2009 21:25:48 +0000 (21:25 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 3 Feb 2009 21:25:48 +0000 (21:25 +0000)
SVN-Revision: 14397

toolchain/binutils/Makefile
toolchain/eglibc/Makefile
toolchain/gcc/Makefile
toolchain/glibc-ports/Makefile
toolchain/glibc/Makefile
toolchain/kernel-headers/Makefile
toolchain/uClibc/Makefile

index 925478c41497df93f229c2fdd388ddb04fe00a01..dba6d456884ed76cd1a9355f5a62ce9fe156b865 100644 (file)
@@ -35,12 +35,30 @@ override CONFIG_AUTOREBUILD=
 
 include $(INCLUDE_DIR)/host-build.mk
 
-EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX))
+BINUTILS_CONFIGURE:= \
+       ./configure \
+               --prefix=$(TOOLCHAIN_DIR)/usr \
+               --build=$(GNU_HOST_NAME) \
+               --host=$(GNU_HOST_NAME) \
+               --target=$(REAL_GNU_TARGET_NAME) \
+               --with-sysroot=$(TOOLCHAIN_DIR) \
+               --disable-multilib \
+               --disable-werror \
+               --disable-nls \
+               $(SOFT_FLOAT_CONFIG_OPTION) \
+               $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
 
 ifneq ($(CONFIG_SSP_SUPPORT),)
-       LIB_SSP:=--enable-libssp
+  BINUTILS_CONFIGURE+= \
+               --enable-libssp
 else
-       LIB_SSP:=--disable-libssp
+  BINUTILS_CONFIGURE+= \
+               --disable-libssp
+endif
+
+ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
+  BINUTILS_CONFIGURE+= \
+               --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
 endif
 
 define Build/Prepare
@@ -51,19 +69,7 @@ endef
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               ./configure \
-               --prefix=$(TOOLCHAIN_DIR)/usr \
-               --build=$(GNU_HOST_NAME) \
-               --host=$(GNU_HOST_NAME) \
-               --target=$(REAL_GNU_TARGET_NAME) \
-               --with-sysroot=$(TOOLCHAIN_DIR) \
-               --disable-multilib \
-               --disable-werror \
-               --disable-nls \
-               $(LIB_SSP) \
-               $(EXTRA_TARGET) \
-               $(SOFT_FLOAT_CONFIG_OPTION) \
-               $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
+               $(BINUTILS_CONFIGURE) \
        );
 endef
 
index e9e1d00da510253dbb8c47cbeac2d6a613ffe3ed..6e4e3e025f347d8792c5205a372c381e49acba2b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,6 +14,7 @@ PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REVISION)
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
+
 ifeq ($(PKG_VERSION),2.6.1)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_6
 endif
@@ -65,9 +66,11 @@ EGLIBC_CONFIGURE:= \
                --enable-add-ons \
 
 ifeq ($(CONFIG_SOFT_FLOAT),)
-  EGLIBC_CONFIGURE+= --with-fp
+  EGLIBC_CONFIGURE+= \
+       --with-fp
 else
-  EGLIBC_CONFIGURE+= --without-fp
+  EGLIBC_CONFIGURE+= \
+       --without-fp
 endif
 
 EGLIBC_MAKE:= \
index 0198e4364165e87e9f2af2243e5a042a6314fd3d..039643db9baa900488346af80c463037cd20baa0 100644 (file)
@@ -63,7 +63,7 @@ PKG_BUILD_DIR2:=$(PKG_BUILD_DIR)-final
 SEP:=,
 TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
 
-GCC_CONFIGURE_COMMON:= \
+GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
        $(PKG_BUILD_DIR)/configure \
                --prefix=$(TOOLCHAIN_DIR)/usr \
@@ -80,37 +80,37 @@ GCC_CONFIGURE_COMMON:= \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
 
 ifneq ($(CONFIG_GCC_VERSION_4_3),)
-       GCC_BUILD_TARGET_LIBGCC:=y
-       GCC_CONFIGURE_COMMON+= \
+  GCC_BUILD_TARGET_LIBGCC:=y
+  GCC_CONFIGURE+= \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float
 endif
 
 ifneq ($(CONFIG_SSP_SUPPORT),)
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --enable-libssp
 else
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --disable-libssp
 endif
 
 ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --enable-biarch \
                --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
 endif
 
 ifeq ($(LIBC),uClibc)
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --disable-__cxa_atexit
 else
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --enable-__cxa_atexit
 endif
 
 GCC_CONFIGURE_STAGE0:= \
-       $(GCC_CONFIGURE_COMMON) \
+       $(GCC_CONFIGURE) \
                --with-newlib \
                --without-headers \
                --enable-languages=c \
@@ -119,7 +119,7 @@ GCC_CONFIGURE_STAGE0:= \
                --disable-threads \
 
 GCC_CONFIGURE_STAGE1:= \
-       $(GCC_CONFIGURE_COMMON) \
+       $(GCC_CONFIGURE) \
                --with-newlib \
                --with-sysroot=$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev \
                --enable-languages=c \
@@ -127,7 +127,7 @@ GCC_CONFIGURE_STAGE1:= \
                --disable-threads \
 
 GCC_CONFIGURE_STAGE2:= \
-       $(GCC_CONFIGURE_COMMON) \
+       $(GCC_CONFIGURE) \
                --enable-languages=$(TARGET_LANGUAGES) \
                --enable-shared \
                --enable-threads \
index 2ddeb4e2be23983ff468cdedc72022749156c7bc..d9e5d0d7f56632149b9abcaa94b50789a53bd748 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,7 +21,6 @@ endif
 
 PKG_SOURCE_URL:=@GNU/glibc/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
 
 PATCH_DIR:=./patches/$(PKG_VERSION)
 
index fd6acc46b881ff6994df3af95c5a68966096a70d..f808615cd42d79857b12d568c42da1a53e04d515 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,7 +21,6 @@ endif
 
 PKG_SOURCE_URL:=@GNU/glibc/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
 
 PATCH_DIR:=./patches/$(PKG_VERSION)
 
@@ -51,7 +50,7 @@ endif
 # http://sourceware.org/bugzilla/show_bug.cgi?id=5203
 GLIBC_CFLAGS:=$(subst -Os,-O2,$(TARGET_CFLAGS))
 
-GLIBC_CONFIGURE_COMMON:= \
+GLIBC_CONFIGURE:= \
        BUILD_CC="$(HOSTCC)" \
        $(TARGET_CONFIGURE_OPTS) \
        CFLAGS="$(GLIBC_CFLAGS)" \
@@ -70,20 +69,20 @@ GLIBC_CONFIGURE_COMMON:= \
                --without-cvs \
 
 ifeq ($(CONFIG_SOFT_FLOAT),)
-  GLIBC_CONFIGURE_COMMON+= \
+  GLIBC_CONFIGURE+= \
                --with-fp
 else
-  GLIBC_CONFIGURE_COMMON+= \
+  GLIBC_CONFIGURE+= \
                --without-fp
 endif
 
 GLIBC_CONFIGURE_STAGE1:= \
-       $(GLIBC_CONFIGURE_COMMON) \
+       $(GLIBC_CONFIGURE) \
                --disable-sanity-checks \
                --enable-hacker-mode \
        
 GLIBC_CONFIGURE_STAGE2:= \
-       $(GLIBC_CONFIGURE_COMMON) \
+       $(GLIBC_CONFIGURE) \
 
 GLIBC_MAKE:= \
        $(MAKE) \
index d787cf0a85a91c56e0616f85beaaf24277d2937f..cf5a3842953af6a17d42f08b0e84ab56c4e8d87d 100644 (file)
@@ -32,6 +32,10 @@ ifeq ($(strip $(BOARD)),uml)
   LINUX_KARCH:=$(ARCH)
 endif
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.18)),1)
+  LINUX_HAS_HEADERS_INSTALL:=y
+endif
+
 KMAKE := $(MAKE) -C $(PKG_BUILD_DIR) \
        ARCH=$(LINUX_KARCH) \
        KBUILD_HAVE_NLS=no \
@@ -50,7 +54,7 @@ define Build/Prepare/pre/powerpc
        fi
 endef
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.18)),1)
+ifneq ($(LINUX_HAS_HEADERS_INSTALL),)
   define Build/Prepare/all
        mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr
        $(KMAKE) \
index 245383021f64c4c971526359e0eabbff2b99f032..45dbcef0c5f9ee3d129307316335d7787b86b773 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -51,8 +51,6 @@ ifeq ($(PKG_VERSION_SNAPSHOT),y)
   PKG_MD5SUM:=
 endif
 
-PKG_CAT:=bzcat
-
 STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
 BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 ifeq ($(PKG_VERSION_SNAPSHOT),y)