Configure IPv6 kernel options in config/Config-kernel.in
authorFelix Fietkau <nbd@openwrt.org>
Mon, 4 Jan 2016 23:30:36 +0000 (23:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 4 Jan 2016 23:30:36 +0000 (23:30 +0000)
Revision 46834 changed IPv6 support from a module to builtin. But
since the configuration of the IPv6 kernel options was left in
package/kernel/linux/modules/netsupport.mk, this means that an
empty kmod-ipv6 module was still being generated (not packaged).

This patch moves the configuration of the IPv6 kernel options to
config/Config-kernel.in to remove this last bit of the module.

Note that CONFIG_IPV6_PRIVACY was dropped (enabled by default
since Linux v3.13), so this option is no longer needed.

See https://github.com/torvalds/linux/commit/5d9efa7ee99eed58388f186c13cf2e2a87e9ceb4

Signed-off-by: Arjen de Korte <arjen+openwrt@de-korte.org>
SVN-Revision: 48132

config/Config-kernel.in
package/kernel/linux/modules/netsupport.mk

index 4be5f53b515e5aea9ad3fb13da0f28c9eb6aa09c..6e79bae34b9d03e29b11deb4c71f844e2d4339b7 100644 (file)
@@ -551,3 +551,26 @@ config KERNEL_SECCOMP
                default n
                help
                  Build kernel with support for seccomp.
+
+#
+# IPv6 configuration
+#
+
+config KERNEL_IPV6
+       def_bool IPV6
+
+if KERNEL_IPV6
+
+       config KERNEL_IPV6_MULTIPLE_TABLES
+               def_bool y
+
+       config KERNEL_IPV6_SUBTREES
+               def_bool y
+
+       config KERNEL_IPV6_MROUTE
+               def_bool y
+
+       config KERNEL_IPV6_PIMSM_V2
+               def_bool n
+
+endif
index 2fa87b99d0e353bf26c487abafa028fe5c7d1128..e3fa9d7b5ae9d82315f82b0caa04de49eacacc57 100644 (file)
@@ -454,28 +454,6 @@ endef
 $(eval $(call KernelPackage,iptunnel6))
 
 
-define KernelPackage/ipv6
-  SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=IPv6 support
-  DEPENDS:=@IPV6
-  HIDDEN:=1
-  DEFAULT:=y
-  KCONFIG:= \
-       CONFIG_IPV6=y \
-       CONFIG_IPV6_PRIVACY=y \
-       CONFIG_IPV6_MULTIPLE_TABLES=y \
-       CONFIG_IPV6_MROUTE=y \
-       CONFIG_IPV6_PIMSM_V2=n \
-       CONFIG_IPV6_SUBTREES=y
-endef
-
-define KernelPackage/ipv6/description
- Kernel modules for IPv6 support
-endef
-
-$(eval $(call KernelPackage,ipv6))
-
-
 define KernelPackage/sit
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   DEPENDS:=@IPV6 +kmod-iptunnel +kmod-iptunnel4