merge: base: update base-files and basic config
authorZoltan HERPAI <wigyori@uid0.hu>
Tue, 7 Nov 2017 08:45:50 +0000 (09:45 +0100)
committerFelix Fietkau <nbd@nbd.name>
Fri, 8 Dec 2017 18:41:18 +0000 (19:41 +0100)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Config.in
Makefile
README
package/base-files/Makefile
package/base-files/files/bin/config_generate
package/base-files/files/etc/init.d/system
package/base-files/files/lib/preinit/10_indicate_preinit
package/base-files/image-config.in
scripts/checkpatch.pl
scripts/config/mconf.c

index ddbc4e2ea40946454e547f906d5859334d93226b..d30c04839e949ca06942e8a41912fb19a2657305 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -4,7 +4,7 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
-mainmenu "LEDE Configuration"
+mainmenu "OpenWrt Configuration"
 
 config MODULES
        option modules
 
 config MODULES
        option modules
index 09db75c5508d49d1bc10f66007149136ca0bcf7c..0a1f96a973d7c30fb991866c11a98f39e42bc604 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ export TOPDIR LC_ALL LANG TZ
 
 empty:=
 space:= $(empty) $(empty)
 
 empty:=
 space:= $(empty) $(empty)
-$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the LEDE directory must not include any spaces))
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
 
 world:
 
 
 world:
 
diff --git a/README b/README
index 405c18bac06b1d9a7b119d1cbe32cccb2f434e24..864ea2f1b90e12873ed10037dd5801887db3e3a2 100644 (file)
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-This is the buildsystem for the LEDE Linux distribution.
+This is the buildsystem for the OpenWrt Linux distribution.
 
 Please use "make menuconfig" to choose your preferred
 configuration for the toolchain and firmware.
 
 Please use "make menuconfig" to choose your preferred
 configuration for the toolchain and firmware.
@@ -23,7 +23,7 @@ the lack of case sensitiveness in the file system.
 
 
 Sunshine!
 
 
 Sunshine!
-       Your LEDE Community
-       http://www.lede-project.org
+       Your OpenWrt Community
+       http://www.openwrt.org
 
 
 
 
index 077bed469df6e0e67a8014a267901a872e84101b..5afb02db2878fce9f9dd12114a2ef7e254d98322 100644 (file)
@@ -34,7 +34,7 @@ define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
   DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:lede-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
   SECTION:=base
   CATEGORY:=Base system
   DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:lede-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
-  TITLE:=Base filesystem for Lede
+  TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
 endef
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
 endef
index a8311fc595babdfeddd6d84ecf21799d0bd4c9f2..bbed567defcf202d43d5821d94b848587392a52a 100755 (executable)
@@ -223,7 +223,7 @@ generate_static_system() {
        uci -q batch <<-EOF
                delete system.@system[0]
                add system system
        uci -q batch <<-EOF
                delete system.@system[0]
                add system system
-               set system.@system[-1].hostname='LEDE'
+               set system.@system[-1].hostname='OpenWrt'
                set system.@system[-1].timezone='UTC'
                set system.@system[-1].ttylogin='0'
                set system.@system[-1].log_size='64'
                set system.@system[-1].timezone='UTC'
                set system.@system[-1].ttylogin='0'
                set system.@system[-1].log_size='64'
@@ -233,10 +233,10 @@ generate_static_system() {
                set system.ntp='timeserver'
                set system.ntp.enabled='1'
                set system.ntp.enable_server='0'
                set system.ntp='timeserver'
                set system.ntp.enabled='1'
                set system.ntp.enable_server='0'
-               add_list system.ntp.server='0.lede.pool.ntp.org'
-               add_list system.ntp.server='1.lede.pool.ntp.org'
-               add_list system.ntp.server='2.lede.pool.ntp.org'
-               add_list system.ntp.server='3.lede.pool.ntp.org'
+               add_list system.ntp.server='0.openwrt.pool.ntp.org'
+               add_list system.ntp.server='1.openwrt.pool.ntp.org'
+               add_list system.ntp.server='2.openwrt.pool.ntp.org'
+               add_list system.ntp.server='3.openwrt.pool.ntp.org'
        EOF
 
        if json_is_a system object; then
        EOF
 
        if json_is_a system object; then
index 8c5f6772996775839f372b0140259e5ac77ee7f6..531aa8cbc548743371eba0232d6cee5d67c4e20e 100755 (executable)
@@ -7,7 +7,7 @@ USE_PROCD=1
 validate_system_section()
 {
        uci_validate_section system system "${1}" \
 validate_system_section()
 {
        uci_validate_section system system "${1}" \
-               'hostname:string:lede' \
+               'hostname:string:OpenWrt' \
                'conloglevel:uinteger' \
                'buffersize:uinteger' \
                'timezone:string:UTC' \
                'conloglevel:uinteger' \
                'buffersize:uinteger' \
                'timezone:string:UTC' \
index 5442a749b182bde2919eb1f10d8ff553be9bb7e4..c3ec7bfdf77bc95d4881755a1ec59711da4448a3 100644 (file)
@@ -113,7 +113,7 @@ preinit_ip() {
                preinit_config_board
        fi
 
                preinit_config_board
        fi
 
-       preinit_net_echo "Doing Lede Preinit\n"
+       preinit_net_echo "Doing OpenWrt Preinit\n"
 }
 
 preinit_ip_deconfig() {
 }
 
 preinit_ip_deconfig() {
index 87d2ac6c5462f915b12607c0e0c46f349f948180..88ec50a8e8647cff4022f8ff493b620e9e0151d4 100644 (file)
@@ -158,7 +158,7 @@ if VERSIONOPT
        config VERSION_DIST
                string
                prompt "Release distribution"
        config VERSION_DIST
                string
                prompt "Release distribution"
-               default "LEDE"
+               default "OpenWrt"
                help
                        This is the name of the release distribution.
                        If unspecified, it defaults to OpenWrt.
                help
                        This is the name of the release distribution.
                        If unspecified, it defaults to OpenWrt.
@@ -201,13 +201,13 @@ if VERSIONOPT
                         %c .. Configured release revision code or value of %R, lowercase
                         %N .. Release name, uppercase
                         %n .. Release name, lowercase
                         %c .. Configured release revision code or value of %R, lowercase
                         %N .. Release name, uppercase
                         %n .. Release name, lowercase
-                        %D .. Distribution name or "Lede", uppercase
-                        %d .. Distribution name or "lede", lowercase
+                        %D .. Distribution name or "OpenWrt", uppercase
+                        %d .. Distribution name or "openwrt", lowercase
                         %T .. Target name
                         %S .. Target/Subtarget name
                         %A .. Package architecture
                         %t .. Build taint flags, e.g. "no-all busybox"
                         %T .. Target name
                         %S .. Target/Subtarget name
                         %A .. Package architecture
                         %t .. Build taint flags, e.g. "no-all busybox"
-                        %M .. Manufacturer name or "Lede"
+                        %M .. Manufacturer name or "OpenWrt"
                         %P .. Product name or "Generic"
                         %h .. Hardware revision or "v0"
 
                         %P .. Product name or "Generic"
                         %h .. Hardware revision or "v0"
 
index 05fd772c91ffd99c36a6fc71817aba1f3129a155..5224ea49c3b27985c3d15928c2748467dce4fdd4 100755 (executable)
@@ -174,7 +174,7 @@ if ($tree) {
        }
 
        if (!defined $root) {
        }
 
        if (!defined $root) {
-               print "Must be run from the top-level dir. of a LEDE tree\n";
+               print "Must be run from the top-level dir. of a OpenWrt tree\n";
                exit(2);
        }
 }
                exit(2);
        }
 }
index c366e21fbacc79b8604f541f04b132cd916610f9..540fa911e10827509c756927c558223dfc4dee5a 100644 (file)
@@ -25,7 +25,7 @@
 static const char mconf_readme[] = N_(
 "Overview\n"
 "--------\n"
 static const char mconf_readme[] = N_(
 "Overview\n"
 "--------\n"
-"Some LEDE features may be built directly into the image.\n"
+"Some OpenWrt features may be built directly into the image.\n"
 "Some may be made into installable ipkg packages. Some features\n"
 "may be completely removed altogether.\n"
 "\n"
 "Some may be made into installable ipkg packages. Some features\n"
 "may be completely removed altogether.\n"
 "\n"