ramips: Add RTC driver to kernel for working hctosys
authorRosen Penev <rosenp@gmail.com>
Sun, 30 Oct 2016 03:50:45 +0000 (20:50 -0700)
committerJohn Crispin <john@phrozen.org>
Mon, 31 Oct 2016 15:41:26 +0000 (16:41 +0100)
Build the RTC driver into the kernel, (and remove the optional module), in order
to make hctosys working. (Currently the module is loaded after hctosys has failed previously)

Signed-off-by: Rosen Penev <rosenp@gmail.com>
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/config-4.4

index 234c7a76d9fcb1d6dceb3060d636abc14e7b847a..e0fbb611198426c17f23c44b4cc00d60bdd82dc5 100644 (file)
@@ -96,7 +96,7 @@ define Device/pbr-m1
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
   DEVICE_TITLE := PBR-M1
   DEVICE_PACKAGES := kmod-usb3 kmod-usb-ledtrig-usbport kmod-ata-core kmod-ata-ahci \
-       kmod-rtc-pcf8563 kmod-i2c-mt7621
+       kmod-i2c-mt7621
 endef
 TARGET_DEVICES += pbr-m1
 
@@ -119,7 +119,7 @@ define Device/witi
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
   DEVICE_TITLE := MQmaker WiTi
   DEVICE_PACKAGES := kmod-usb3 kmod-usb-ledtrig-usbport kmod-ata-core kmod-ata-ahci \
-       kmod-rtc-pcf8563 kmod-i2c-mt7621
+       kmod-i2c-mt7621
 endef
 TARGET_DEVICES += witi
 
index 9132d894df53950947d7c9377f1356ad8c640634..47b208b7730b763bf598915fdaa787265b4b6375 100644 (file)
@@ -214,6 +214,7 @@ CONFIG_RESET_CONTROLLER=y
 CONFIG_RFS_ACCEL=y
 CONFIG_RPS=y
 CONFIG_RTC_CLASS=y
+CONFIG_RTC_DRV_PCF8563=y
 CONFIG_SCHED_HRTICK=y
 # CONFIG_SCHED_INFO is not set
 CONFIG_SCHED_SMT=y