x86: amd-xgbe: add missing dependencies on 5.10
authorChuanhong Guo <gch981213@gmail.com>
Sun, 18 Apr 2021 10:05:08 +0000 (18:05 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Sun, 18 Apr 2021 10:05:08 +0000 (18:05 +0800)
fix the following build error when building with test kernel:

Package kmod-amd-xgbe is missing dependencies for the following libraries:
mdio_devres.ko

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/x86/modules.mk

index 41295d2d1f37c23937ab24a7ee66d8e86acdd1ec..d31e4535df48c4d97c4275ef7637934ed592d234 100644 (file)
@@ -22,7 +22,7 @@ $(eval $(call KernelPackage,amazon-ena))
 define KernelPackage/amd-xgbe
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=AMD Ethernet on SoC support
-  DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy
+  DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy +LINUX_5_10:kmod-mdio-devres
   KCONFIG:=CONFIG_AMD_XGBE
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/amd/xgbe/amd-xgbe.ko
   AUTOLOAD:=$(call AutoLoad,35,amd-xgbe)