uboot-envtools: Change download to git.
authorRosen Penev <rosenp@gmail.com>
Tue, 1 May 2018 19:59:05 +0000 (12:59 -0700)
committerJohn Crispin <john@phrozen.org>
Wed, 2 May 2018 07:18:26 +0000 (09:18 +0200)
Currently, the build system uses an openwrt mirror which does not currently
work and FTP can be unreliable under several circumstances. This change
implicitly allows using all the mirrors to download.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/boot/uboot-envtools/Makefile

index 8de6455b1e8ad03770bcdea7e65126f6badf6141..2f8dd0ae64ffb2ad737527710b859a6bfbed1357 100644 (file)
@@ -12,12 +12,13 @@ PKG_DISTNAME:=u-boot
 PKG_VERSION:=2018.03
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=\
-       http://mirror2.openwrt.org/sources \
-       ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_SUBDIR:=$(PKG_DISTNAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_DISTNAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://git.denx.de/u-boot.git
+PKG_SOURCE_VERSION:=f95ab1fb6e37f0601f397091bb011edf7a98b890
+PKG_MIRROR_HASH:=b50d8b6fe0d90b92c8c147457b1b4c2ed1cdb03191085cfc57fdad77c0bfffab
 
 PKG_BUILD_DEPENDS:=fstools