dropbear: add missing zlib dependency for dropbearconvert
authorMatt Merhar <mattmerhar@protonmail.com>
Wed, 1 Jan 2020 07:58:34 +0000 (02:58 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 5 Jan 2020 18:36:45 +0000 (19:36 +0100)
If CONFIG_DROPBEAR_ZLIB is set, building fails at the packaging stage
due to an undeclared dependency on libz.so.1.

As is already done for the main dropbear package, conditionally add a
dependency on zlib.

Signed-off-by: Matt Merhar <mattmerhar@protonmail.com>
package/network/services/dropbear/Makefile

index 75a3264ebbe79a8b5a399a146f670db52d694f9f..c55af45428455571d0debaccaf17ef23445a0e64 100644 (file)
@@ -72,6 +72,7 @@ define Package/dropbearconvert
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Utility for converting SSH keys
+  DEPENDS:= +DROPBEAR_ZLIB:zlib
 endef
 
 CONFIGURE_ARGS += \