mvebu: clearfog: include DTB for all variants in image
authorJosua Mayer <josua.mayer97@gmail.com>
Mon, 22 May 2017 15:04:19 +0000 (17:04 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 30 May 2017 12:00:30 +0000 (14:00 +0200)
Installing all armada-388-clearfog-* DTBs in the same sdcard image,
it now becomes much easier to swap sdcards between different device variants.

Signed-off-by: Josua Mayer <josua.mayer97@gmail.com>
target/linux/mvebu/image/Makefile

index f112bb9a1e2327e717afe46dffc01bc364b151ab..b5014161c62412e7a68b4c877ed3f03f4957dff5 100644 (file)
@@ -36,7 +36,7 @@ endef
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot 16384
-       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb)
+       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb;)
        mcopy -i $@.boot $(IMAGE_KERNEL) ::zImage
        mcopy -i $@.boot $@.bootscript ::boot.scr
 endef
@@ -178,18 +178,19 @@ TARGET_DEVICES += armada-388-rd
 
 define Device/armada-388-clearfog-pro
   KERNEL_INSTALL := 1
-  KERNEL := dtb | kernel-bin
+  KERNEL := kernel-bin
   DEVICE_TITLE := SolidRun ClearFog Pro
   DEVICE_PACKAGES := mkf2fs e2fsprogs swconfig kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := boot-scr-cfpro | boot-img | sdcard-img | gzip | append-metadata
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+  DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
 endef
 TARGET_DEVICES += armada-388-clearfog-pro
 
 define Device/armada-388-clearfog-base
   KERNEL_INSTALL := 1
-  KERNEL := dtb | kernel-bin
+  KERNEL := kernel-bin
   DEVICE_TITLE := SolidRun ClearFog Base
   DEVICE_PACKAGES := \
          kmod-nls-cp437 kmod-nls-iso8859-1 \
@@ -199,6 +200,7 @@ define Device/armada-388-clearfog-base
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := boot-scr-cfbase | boot-img | sdcard-img | gzip
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+  DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
 endef
 TARGET_DEVICES += armada-388-clearfog-base