brcm63xx: Add DT support for VR-3025u
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:32 +0000 (11:28 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:32 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
[jogo: make linux partition writable]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42241

target/linux/brcm63xx/dts/vr-3025u.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/comtrend.mk

diff --git a/target/linux/brcm63xx/dts/vr-3025u.dts b/target/linux/brcm63xx/dts/vr-3025u.dts
new file mode 100644 (file)
index 0000000..86fde1c
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6368.dtsi"
+
+/ {
+       model = "Comtrend VR-3025u";
+       compatible = "comtrend,vr-3025u", "brcm,bcm6368";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x0000000 0x0020000>;
+               read-only;
+       };
+
+       linux@20000 {
+               label = "linux";
+               reg = <0x0020000 0x1fc0000>;
+       };
+
+       nvram@1fe0000 {
+               label = "nvram";
+               reg = <0x1fe0000 0x020000>;
+       };
+};
index a04709aa167a96277613f01472fde811f9885f82..fc759785dc36071a989c0f9cd66066329498da30 100755 (executable)
@@ -271,8 +271,6 @@ define Image/Build
        # Sagem F@ST2504n
        $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
 
-       # Comtrend VR-3025u
-       $(call Image/Build/CFE,$(1),96368M-1541N,6368,VR-3025u,,--pad 16)
        # Comtrend VR-3025un
        $(call Image/Build/CFE,$(1),96368M-1341N,6368,VR-3025un,,--pad 4)
        # Comtrend WAP-5813n
@@ -363,6 +361,8 @@ $(eval $(call CfeImageDTB,CT536_CT5621,ct536plus,96348GW-11,6348,CT536_CT5621))
 $(eval $(call CfeImageDTB,CT5365,ct-5365,96348A-122,6348,CT-5365))
 # Comtrend CT-6373
 $(eval $(call CfeImageDTB,CT6373,ct-6373,CT6373-1,6358,CT-6373))
+# Comtrend VR-3025u
+$(eval $(call CfeImageDTB,VR3025u,vr-3025u,96368M-1541N,6368,VR-3025u,,--pad 16 --image-offset 0x20000 --block-size 0x20000))
 # D-Link DSL-2740B/DSL-2741B, rev C2
 $(eval $(call CfeImageDTB,DSL274XB_C,dsl-274xb-c,96358GW,6358,DSL274XB-C2))
 # D-Link DSL-2740B/DSL-2741B, rev C3
index 9bf57b9afa56240512d518f43db07b68c5139a77..25b7123c72e40c7e0257c015fec9df1f20cb6a72 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4169,6 +4169,116 @@ static struct board_info __initdata boar
+@@ -4169,6 +4169,117 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
@@ -15,6 +15,7 @@
 +
 +static struct board_info __initdata board_VR3025u = {
 +      .name                                   = "96368M-1541N",
++      .of_board_id                    = "comtrend,vr-3025u",
 +      .expected_cpu_id                = 0x6368,
 +
 +      .has_uart0                              = 1,
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4658,6 +4768,7 @@ static const struct board_info __initcon
+@@ -4658,6 +4769,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index bb7597a464fb8a2681c8a64076c3cddd03796ea2..5b18b72e4582e80c29c8f05be0339dbecb0eecb2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4279,6 +4279,116 @@ static struct board_info __initdata boar
+@@ -4280,6 +4280,116 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4769,6 +4879,7 @@ static const struct board_info __initcon
+@@ -4770,6 +4880,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 4aefa3380c8478cf89f1e43a32ffe2830f30f881..3ee2dd5d7ad5b20f29e40010a22cc2ac3460bf9d 100644 (file)
@@ -96,8 +96,8 @@
 +
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
-       .expected_cpu_id                = 0x6368,
-@@ -4878,6 +4968,7 @@ static const struct board_info __initcon
+       .of_board_id                    = "comtrend,vr-3025u",
+@@ -4879,6 +4969,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 7f9292f242b617882638b738a51811d4099db5a5..a686ef6a8d8b30addd6e9a8c2ba0483ff5a74b1b 100644 (file)
@@ -57,7 +57,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -4952,6 +5002,7 @@ static const struct board_info __initcon
+@@ -4953,6 +5003,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 6d0611a2b991b197fca1c423b5ae37ef760873ad..0fbb1758dbaa0e7c09ab5b989703888c56e91958 100644 (file)
@@ -96,7 +96,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -4953,6 +5042,7 @@ static const struct board_info __initcon
+@@ -4954,6 +5043,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index bdf7690f4cf39b55ecbf78ddc42fe2392a4ccfd5..2bb41de61a64fe00b00913acbbb3b7313e0224d5 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5036,6 +5171,7 @@ static const struct board_info __initcon
+@@ -5037,6 +5172,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 6118c271653961cb607e66f5eef550135c643c31..ab9b61253c473b4f76d905918844139ec0ea59db 100644 (file)
@@ -52,3 +52,13 @@ define Profile/CT6373/Description
   Package set optimized for CT-6373.
 endef
 $(eval $(call Profile,CT6373))
+
+define Profile/VR3025u
+  NAME:=Comtrend VR-3025u
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/VR3025u/Description
+  Package set optimized for VR-3025u.
+endef
+$(eval $(call Profile,VR3025u))