ramips: Add support for ZTE Q7
authorJohn Crispin <john@openwrt.org>
Wed, 1 Apr 2015 08:31:46 +0000 (08:31 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 1 Apr 2015 08:31:46 +0000 (08:31 +0000)
ZTE Q7 is a wireless router with SD Card,USB,1 ethernet port and a battery.It used MT7620a SoC.
I can,t find any information about this router on ZTE's website.
But I found this : http://en.cctairmobi.com/plus/list.php?tid=40
This router is the same as ZTE Q7 and later I found that both routers are made by the same company:-D

This patch adds support for it.
Because there is only one port,I disabled VLAN and use eth0 as lan port.
I could only create a sysupgrade firmware because I don't know how the orignal webpage check the uploaded image:-(

Signed-off-by: 郭传鈜 <gch981213@gmail.com>
SVN-Revision: 45208

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ZTE-Q7.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index bfe1c0c7f20d21b0f32892d6cb9c3c97954b7618..56ba3b73cee0edfcebf803d051ec34b53220042e 100755 (executable)
@@ -237,6 +237,9 @@ case $board in
                set_usb_led "lenovo:blue:usb"
                set_wifi_led "lenovo:blue:wifi"
                ;;
+       zte-q7)
+               set_wifi_led "zte:blue:status"
+               ;;
 esac
 
 board_config_flush
index 89d168106216a2c201397d76d30221e2eb2aaf1e..d4ec19d6cdda425c388ac3529639609927c5478f 100755 (executable)
@@ -46,6 +46,7 @@ ramips_setup_interfaces()
        3g150b | \
        3g300m | \
        w150m | \
+       zte-q7 | \
        all0256n | \
        all5002 | \
        all5003 | \
index 50b6ff24ca839fcd4d3f11d50809c1d424f1ab49..5301593f650fa8f7a1ea486e98104ef03f122faa 100644 (file)
@@ -224,6 +224,9 @@ get_status_led() {
        y1s)
                status_led="lenovo:blue:power"
                ;;
+       zte-q7)
+               status_led="zte:red:status"
+               ;;
        esac
 }
 
index 4527414e6e6cdf22293ff6088af1f00624459292..fc6eb3769230cc6b1f90913c0ed293a2b528242c 100755 (executable)
@@ -379,6 +379,9 @@ ramips_board_detect() {
        *"ZBT WR8305RT")
                name="wr8305rt"
                ;;
+       *"ZTE Q7")
+               name="zte-q7"
+               ;;
        *"Lenovo Y1")
                name="y1"
                ;;
index fffbe72cb8dc3927b7bf70da091be4f228961ef5..a5773b5e4daa35f58b1f3ea899a4cb426df819d4 100755 (executable)
@@ -114,6 +114,7 @@ platform_check_image() {
        xiaomi-miwifi-mini |\
        y1 |\
        y1s |\
+       zte-q7 |\
        zbt-wa05)
                [ "$magic" != "27051956" ] && {
                        echo "Invalid image type."
diff --git a/target/linux/ramips/dts/ZTE-Q7.dts b/target/linux/ramips/dts/ZTE-Q7.dts
new file mode 100644 (file)
index 0000000..9efc35e
--- /dev/null
@@ -0,0 +1,111 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "ZTE-Q7", "ralink,mt7620a-soc";
+       model = "ZTE Q7";
+
+       palmbus@10000000 {
+
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "en25q64";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "en25q64";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "ephy", "wled", "nd_sd";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               pinctrl-names = "default";
+               pinctrl-0 = <&ephy_pins>;
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "wllll";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       sdhci@10130000 {
+               status = "okay";
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               statred {
+                       label = "zte:red:status";
+                       gpios = <&gpio0 13 1>;
+               };
+               statblue {
+                       label = "zte:blue:status";
+                       gpios = <&gpio0 9 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio1 2 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
index 14f6f1ef7e6bcafde7a1aa134d70b2a8adf0551d..743f7b4cf66afd7ea80e465e868baeba415175b1 100644 (file)
@@ -862,6 +862,7 @@ Image/Build/Profile/WR8305RT=$(call BuildFirmware/Default8M/$(1),$(1),wr8305rt,W
 Image/Build/Profile/WRTNODE=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode,WRTNODE)
 Image/Build/Profile/WT3020=$(call BuildFirmware/PorayDualSize/$(1),$(1),wt3020,WT3020)
 Image/Build/Profile/XIAOMI-MIWIFI-MINI=$(call BuildFirmware/Default16M/$(1),$(1),xiaomi-miwifi-mini,XIAOMI-MIWIFI-MINI)
+Image/Build/Profile/ZTE-Q7=$(call BuildFirmware/Default8M/$(1),$(1),zte-q7,ZTE-Q7)
 Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
 Image/Build/Profile/ArcherC20i=$(call BuildFirmware/Tplink/$(1),$(1),ArcherC20i,ArcherC20i)
 
@@ -891,6 +892,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/WRTNODE,$(1))
        $(call Image/Build/Profile/WT3020,$(1))
        $(call Image/Build/Profile/XIAOMI-MIWIFI-MINI,$(1))
+       $(call Image/Build/Profile/ZTE-Q7,$(1))
        $(call Image/Build/Profile/ZBT-WA05,$(1))
        $(call Image/Build/Profile/ArcherC20i,$(1))
 endef