link hotplug2 against libbsd when eglibc is used
authorMirko Vogt <mirko@openwrt.org>
Mon, 13 Jun 2011 13:16:11 +0000 (13:16 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 13 Jun 2011 13:16:11 +0000 (13:16 +0000)
SVN-Revision: 27170

package/hotplug2/Makefile

index 7e1dda7a04aa898f55b891f5c5a85b53bf6b2ec7..9625ba27f9c1dfab07daffe9ca7092991de3f264 100644 (file)
@@ -28,6 +28,7 @@ define Package/hotplug2
   VERSION:=1.0-beta-$(PKG_RELEASE)
   TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
+  DEPENDS:=+USE_EGLIBC:libbsd
 endef
 
 define Package/hotplug2/description
@@ -44,9 +45,13 @@ MAKE_FLAGS += \
        COPTS="$(TARGET_CFLAGS)" \
        STATIC_WORKER="fork"
 
+ifneq ($(CONFIG_USE_EGLIBC),)
+  TARGET_LDFLAGS += -lbsd
+endif
+
 define Build/Compile
        $(call Build/Compile/Default)
-       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
+       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
 endef
 
 define Package/hotplug2/install