Revert "[package/block-mount] remove example config file"
authorMirko Vogt <mirko@openwrt.org>
Wed, 8 Jun 2011 20:45:19 +0000 (20:45 +0000)
committerMirko Vogt <mirko@openwrt.org>
Wed, 8 Jun 2011 20:45:19 +0000 (20:45 +0000)
This isn't needed anymore due to commit 27138

SVN-Revision: 27139

package/block-mount/Makefile
package/block-mount/files/fstab.config [new file with mode: 0644]

index ac6c5f3ce6b080da41c0e8b353e6c6f758483c92..c2c9d33f134e53eca6057290a5785d90cfb5cd62 100644 (file)
@@ -48,6 +48,8 @@ endef
 define Package/block-mount/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/fstab.config $(1)/etc/config/fstab
        $(INSTALL_DIR) $(1)/lib/functions/fsck
        $(INSTALL_DATA) ./files/mount.sh $(1)/lib/functions/
        $(INSTALL_DATA) ./files/fsck.sh $(1)/lib/functions/
diff --git a/package/block-mount/files/fstab.config b/package/block-mount/files/fstab.config
new file mode 100644 (file)
index 0000000..de52e20
--- /dev/null
@@ -0,0 +1,20 @@
+config global automount
+       option from_fstab 1
+       option anon_mount 1
+       
+config global autoswap
+       option from_fstab 1
+       option anon_swap 0
+       
+config mount
+       option target   /home
+       option device   /dev/sda1
+       option fstype   ext4
+       option options  rw,sync
+       option enabled  0
+       option enabled_fsck 0
+
+config swap
+       option device   /dev/sda2
+       option enabled  0
+