add hotplug2
authorFelix Fietkau <nbd@openwrt.org>
Sun, 4 Mar 2007 19:55:47 +0000 (19:55 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 4 Mar 2007 19:55:47 +0000 (19:55 +0000)
SVN-Revision: 6510

package/hotplug2/Makefile [new file with mode: 0644]

diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
new file mode 100644 (file)
index 0000000..8c8603f
--- /dev/null
@@ -0,0 +1,42 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 6372 2007-02-25 23:34:57Z nbd $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=hotplug2
+PKG_VERSION:=0.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
+PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/hotplug2
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@LINUX_2_6
+  TITLE:=Dynamic device management subsystem for embedded systems
+  URL:=http://isteve.bofh.cz/~isteve/hotplug2/
+endef
+
+define Package/hotplug2/description
+Hotplug2 is a trivial replacement of some of the UDev functionality
+in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
+endef
+
+define Package/hotplug2/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,hotplug2))