packages: some (e)glibc fixes after r44701
authorNicolas Thill <nico@openwrt.org>
Mon, 16 Mar 2015 12:25:06 +0000 (12:25 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 16 Mar 2015 12:25:06 +0000 (12:25 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 44842

package/devel/perf/Makefile
package/libs/libbsd/Makefile
package/network/services/hostapd/Makefile
package/network/services/igmpproxy/Makefile
package/network/services/lldpd/Makefile
package/network/services/samba36/Makefile
package/network/utils/iproute2/Makefile
package/network/utils/iputils/Makefile
package/system/fstools/Makefile
package/system/procd/Makefile
package/system/ubox/Makefile

index 3899b48d82cbefb5d83278d38c80ebf143570720..7cf504cedbc7db7de51660e9cada617f1d4fe7fc 100644 (file)
@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= @USE_EGLIBC +libelf1 +libdw +libpthread +librt +binutils
+  DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org
index 3c12d9f65be8644cd6e6cf4231a4d20bb3e3d59f..fb38837e45f6b5efc2eb3efe1ec0e7e3f9f0b45b 100644 (file)
@@ -18,7 +18,7 @@ PKG_INSTALL:=1
 define Package/libbsd
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=@USE_EGLIBC
+  DEPENDS:=@USE_GLIBC
   TITLE:=common BSD library
 endef
 
index d1bbab86e786ef06a9e280916e8b90cac2e6e884..eeba02802a2f5858b8459eabe0dee6fec999a087 100644 (file)
@@ -89,7 +89,7 @@ ifneq ($(LOCAL_TYPE),hostapd)
        CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
 endif
 
-ifdef CONFIG_USE_EGLIBC
+ifdef CONFIG_USE_GLIBC
   TARGET_LDFLAGS += -lrt
   TARGET_LDFLAGS_C += -lrt
 endif
index 33ed014040706174ef427b066b3b1b5aff14d4b4..03ad25819b5f1872d2044fae9486464a1a41d5c2 100644 (file)
@@ -25,7 +25,7 @@ define Package/igmpproxy
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
-  DEPENDS:=+USE_EGLIBC:librt
+  DEPENDS:=+USE_GLIBC:librt
   TITLE:=Multicast Routing Daemon
   URL:=http://sourceforge.net/projects/igmpproxy
 endef
index 6f97f45e65b3112b35f8f4bfcb5c7c687afe6db6..f038a340ac5f8c24de1ed0ef9ed6b72f7c9412d5 100644 (file)
@@ -31,7 +31,7 @@ define Package/lldpd
   SUBMENU:=Routing and Redirection
   TITLE:=Link Layer Discovery Protocol daemon
   URL:=https://github.com/vincentbernat/lldpd/wiki
-  DEPENDS:=+libevent2 +USE_EGLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
+  DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
   USERID:=lldp=121:lldp=129
   MENU:=1
 endef
index d4c96d3854a4dbfc66106f837a05ec7fffd1cea2..70dfb2b16f6ff796a7483def5c27e8e0e2d871f8 100644 (file)
@@ -35,7 +35,7 @@ define Package/samba36-server
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS server
   URL:=http://www.samba.org/
-  DEPENDS:=+USE_EGLIBC:librt
+  DEPENDS:=+USE_GLIBC:librt
 endef
 
 define Package/samba36-client
index 56d2897e2a6b92fa327632e0eaaf598434d88216..a2dae6d61b65668d36c913bc3a3d11d1445b2ebf 100644 (file)
@@ -82,10 +82,8 @@ define Build/Configure
                > $(PKG_BUILD_DIR)/include/SNAPSHOT.h
 endef
 
-ifdef CONFIG_USE_EGLIBC
-  ifndef CONFIG_EGLIBC_VERSION_2_13
-    TARGET_CFLAGS += -DHAVE_SETNS
-  endif
+ifdef CONFIG_USE_GLIBC
+  TARGET_CFLAGS += -DHAVE_SETNS
 endif
 ifdef CONFIG_USE_MUSL
   TARGET_CFLAGS += -DHAVE_SETNS
index 1dc993cb8131013e97edcc2e253e88fcf70f616c..8d7b84d6b5a2056d775ed7d20c6752feaf2c23e4 100644 (file)
@@ -68,7 +68,7 @@ endef
 define Package/iputils-ping6
 $(call Package/iputils/Default)
   TITLE:=iputils - ping6
-  DEPENDS+= @IPV6 +USE_EGLIBC:libopenssl
+  DEPENDS+= @IPV6 +USE_GLIBC:libopenssl
 endef
 
 define Package/iputils-ping6/description
index 054be0f43f571a9f406e0a619ae9c7ebe11df6c7..9040fd94172a6e4ee54d7d5b4bc75e0df66b413b 100644 (file)
@@ -30,13 +30,13 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
 
 define Package/fstools
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubox +USE_EGLIBC:librt +NAND_SUPPORT:ubi-utils
+  DEPENDS:=+ubox +USE_GLIBC:librt +NAND_SUPPORT:ubi-utils
   TITLE:=OpenWrt filesystem tools
   MENU:=1
 endef
index 02520606e8c6881025c80df55fa467b6a45f7eb5..6f9e6f8562981e5656810b98289c21f32d62d0c0 100644 (file)
@@ -27,12 +27,12 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 
 define Package/procd
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
+  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_GLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
   TITLE:=OpenWrt system process manager
 endef
 
index b58eb16b4d1045ffa21065386c60b18e82a3f583..5a51dc08dc4353a906ce8f6167c9b32f81a9f468 100644 (file)
@@ -20,12 +20,12 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 
 define Package/ubox
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+libubox +ubusd +ubus +libubus +libuci +USE_EGLIBC:librt
+  DEPENDS:=+libubox +ubusd +ubus +libubus +libuci +USE_GLIBC:librt
   TITLE:=OpenWrt system helper toolbox
 endef