load of ide modules at boot (closes: #439)
authorNicolas Thill <nico@openwrt.org>
Sat, 1 Apr 2006 14:51:48 +0000 (14:51 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 1 Apr 2006 14:51:48 +0000 (14:51 +0000)
SVN-Revision: 3565

openwrt/target/linux/Config.in
openwrt/target/linux/generic-2.4/modules.mk

index e81b099be730b9ab53f31f19de89f2b6878a23dc..7a416753ad75b0dea487eaef49c03d7f4d2c1b1f 100644 (file)
@@ -287,6 +287,12 @@ config BR2_PACKAGE_KMOD_IDE
        help
          Kernel modules for IDE support
          useful for usb mass storage devices (e.g. on WL-HDD)
        help
          Kernel modules for IDE support
          useful for usb mass storage devices (e.g. on WL-HDD)
+         
+         Includes:
+           - ide-core
+           - ide-detect
+           - ide-disk
+           - pdc202xx_old
 
 config BR2_PACKAGE_KMOD_LOOP
        prompt "kmod-loop......................... Loop mount support"
 
 config BR2_PACKAGE_KMOD_LOOP
        prompt "kmod-loop......................... Loop mount support"
index 705b702e83740b3fdb52ae351229e0e67c286aa2..f35e9ba56b8b42cb26018ab7ec794e029766e3ca 100644 (file)
@@ -110,7 +110,7 @@ $(eval $(call KMOD_template,IP6TABLES,ip6tables,\
 $(eval $(call KMOD_template,IDE,ide,\
        $(MODULES_DIR)/kernel/drivers/ide/*.o \
        $(MODULES_DIR)/kernel/drivers/ide/*/*.o \
 $(eval $(call KMOD_template,IDE,ide,\
        $(MODULES_DIR)/kernel/drivers/ide/*.o \
        $(MODULES_DIR)/kernel/drivers/ide/*/*.o \
-,CONFIG_IDE))
+,CONFIG_IDE,,20,pdc202xx_old ide-core ide-detect ide-disk))
 
 $(eval $(call KMOD_template,LOOP,loop,\
     $(MODULES_DIR)/kernel/drivers/block/loop.o \
 
 $(eval $(call KMOD_template,LOOP,loop,\
     $(MODULES_DIR)/kernel/drivers/block/loop.o \