ramips: use generic board detection for Unielec u7621-06
authorMathias Kresin <dev@kresin.me>
Tue, 27 Nov 2018 23:31:10 +0000 (00:31 +0100)
committerMathias Kresin <dev@kresin.me>
Tue, 27 Nov 2018 23:50:35 +0000 (00:50 +0100)
Use the generic board detection for the board instead of the target
specific one. Mark the sysupgrade image compatible with the former used
userspace boardname to allow an upgrade from earlier versions.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/image/mt7621.mk

index cdba37d38f7fb39ca28667cb5b8249c90bbbadb6..bb7069a77a591357be07f12be77b757e3670261e 100755 (executable)
@@ -115,7 +115,7 @@ ramips_setup_interfaces()
        rt-n12p|\
        sap-g3200u3|\
        sk-wb8|\
-       u7621-06-256M-16M|\
+       unielec,u7621-06-256m-16m|\
        vr500|\
        wavlink,wl-wn570ha1|\
        wf-2881|\
index 5741cbd2ee13f309dc5cc93f1d48f5a97e0da970..307ab35c3c8df08f85fe1ed924d89613cc6e093a 100755 (executable)
@@ -502,9 +502,6 @@ ramips_board_detect() {
        *"U25AWF-H1")
                name="u25awf-h1"
                ;;
-       *"U7621-06 (256M RAM/16M flash)")
-               name="u7621-06-256M-16M"
-               ;;
        *"U7628-01 (128M RAM/16M flash)")
                name="u7628-01-128M-16M"
                ;;
index fc73f37e29e76e0a9edc428062249666289f30a4..8c720192976c8afa9403e42e9349e95e66aee5a3 100755 (executable)
@@ -162,7 +162,7 @@ platform_check_image() {
        timecloud|\
        tiny-ac|\
        u25awf-h1|\
-       u7621-06-256M-16M|\
+       unielec,u7621-06-256m-16m|\
        u7628-01-128M-16M|\
        ur-326n4g|\
        ur-336un|\
index e0c2f55ad19ec0f2869933b925061d84766327b4..e6059e6977cf9ac4d159af49f697e9dc22f033a6 100644 (file)
@@ -366,14 +366,6 @@ define Device/timecloud
 endef
 TARGET_DEVICES += timecloud
 
-define Device/u7621-06-256M-16M
-  DTS := U7621-06-256M-16M
-  IMAGE_SIZE := 16064k
-  DEVICE_TITLE := UniElec U7621-06 (256M RAM/16M flash)
-  DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
-endef
-TARGET_DEVICES += u7621-06-256M-16M
-
 define Device/ubnt-erx
   DTS := UBNT-ERX
   FILESYSTEMS := squashfs
@@ -394,6 +386,15 @@ define Device/ubnt-erx-sfp
 endef
 TARGET_DEVICES += ubnt-erx-sfp
 
+define Device/unielec_u7621-06-256m-16m
+  DTS := U7621-06-256M-16M
+  IMAGE_SIZE := 16064k
+  DEVICE_TITLE := UniElec U7621-06 (256M RAM/16M flash)
+  DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
+  SUPPORTED_DEVICES += u7621-06-256M-16M
+endef
+TARGET_DEVICES += unielec_u7621-06-256m-16m
+
 define Device/vr500
   DTS := VR500
   IMAGE_SIZE := 66453504