ramips: fix mt76x8 dependencies
authorJohn Crispin <john@phrozen.org>
Tue, 5 Sep 2017 06:08:36 +0000 (08:08 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 5 Sep 2017 06:08:36 +0000 (08:08 +0200)
The commit merging mt7628 and mt7688 failed to update some
dependencies.

Signed-off-by: John Crispin <john@phrozen.org>
package/kernel/mt76/Makefile
target/linux/ramips/modules.mk

index 8fa3267180c897aaad07466111a1273d72dbceae..2a10f1a7a76567bca0efd65f322ccaccb885af52 100644 (file)
@@ -96,7 +96,7 @@ endef
 
 define KernelPackage/mt7603/install
        $(INSTALL_DIR) $(1)/lib/firmware
-       cp $(if $(CONFIG_TARGET_ramips_mt7628)$(CONFIG_TARGET_ramips_mt7688), \
+       cp $(if $(CONFIG_TARGET_ramips_mt76x8), \
                $(PKG_BUILD_DIR)/firmware/mt7628_e1.bin \
                $(PKG_BUILD_DIR)/firmware/mt7628_e2.bin \
                ,\
index 870f2d5c432fd49a52ff22bb8085848908f02fff..95dfd78d05e8a0abcdb963f418575a85f3c743ef 100644 (file)
@@ -10,7 +10,7 @@ OTHER_MENU:=Other modules
 define KernelPackage/pwm-mediatek
   SUBMENU:=Other modules
   TITLE:=MT7628 PWM
-  DEPENDS:=@(TARGET_ramips_mt7628||TARGET_ramips_mt7688)
+  DEPENDS:=@(TARGET_ramips_mt76x8)
   KCONFIG:= \
        CONFIG_PWM=y \
        CONFIG_PWM_MEDIATEK \
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,pwm-mediatek))
 define KernelPackage/sdhci-mt7620
   SUBMENU:=Other modules
   TITLE:=MT7620 SDCI
-  DEPENDS:=@(TARGET_ramips_mt7620||TARGET_ramips_mt7628||TARGET_ramips_mt7621||TARGET_ramips_mt7688) +kmod-mmc
+  DEPENDS:=@(TARGET_ramips_mt7620||TARGET_ramips_mt76x8||TARGET_ramips_mt7621) +kmod-mmc
   KCONFIG:= \
        CONFIG_MTK_MMC \
        CONFIG_MTK_AEE_KDUMP=n \
@@ -48,7 +48,7 @@ define KernelPackage/i2c-ralink
   $(call i2c_defaults,$(I2C_RALINK_MODULES),59)
   TITLE:=Ralink I2C Controller
   DEPENDS:=kmod-i2c-core @TARGET_ramips \
-       @!(TARGET_ramips_mt7621||TARGET_ramips_mt7628||TARGET_ramips_mt7688)
+       @!(TARGET_ramips_mt7621||TARGET_ramips_mt76x8)
 endef
 
 define KernelPackage/i2c-ralink/description
@@ -65,7 +65,7 @@ define KernelPackage/i2c-mt7628
   $(call i2c_defaults,$(I2C_MT7621_MODULES),59)
   TITLE:=MT7628/88 I2C Controller
   DEPENDS:=kmod-i2c-core \
-       @(TARGET_ramips_mt7628||TARGET_ramips_mt7688)
+       @(TARGET_ramips_mt76x8)
 endef
 
 define KernelPackage/i2c-mt7628/description